summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythinstall
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-15 05:32:41 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-15 05:32:41 (GMT)
commit620cb6800d15e6b2b0738b6cdd29080d2685f70b (patch)
tree44e096ea99d29a83c190bc2fff49569a1b00092a /abs/core-testing/mythinstall
parentac3fcc84dfa0692cf2b11a04d7266da47c2ff89c (diff)
downloadlinhes_pkgbuild-620cb6800d15e6b2b0738b6cdd29080d2685f70b.zip
linhes_pkgbuild-620cb6800d15e6b2b0738b6cdd29080d2685f70b.tar.gz
linhes_pkgbuild-620cb6800d15e6b2b0738b6cdd29080d2685f70b.tar.bz2
LinHES-config mythinstall: various timezone fixups
Diffstat (limited to 'abs/core-testing/mythinstall')
-rw-r--r--abs/core-testing/mythinstall/PKGBUILD2
-rwxr-xr-xabs/core-testing/mythinstall/installdialog.cpp1
-rwxr-xr-xabs/core-testing/mythinstall/installsettings.cpp12
-rwxr-xr-xabs/core-testing/mythinstall/misc_settings.cpp12
-rwxr-xr-xabs/core-testing/mythinstall/mv_common.h2
-rwxr-xr-xabs/core-testing/mythinstall/mythinstallbin1068165 -> 0 bytes
6 files changed, 22 insertions, 7 deletions
diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index 5687032..6fea8ed 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=1
-pkgrel=5
+pkgrel=8
pkgdesc="LinHES installer/systemconfig GUI."
arch=i686
depends=()
diff --git a/abs/core-testing/mythinstall/installdialog.cpp b/abs/core-testing/mythinstall/installdialog.cpp
index 5349453..e5bdfc9 100755
--- a/abs/core-testing/mythinstall/installdialog.cpp
+++ b/abs/core-testing/mythinstall/installdialog.cpp
@@ -364,7 +364,6 @@ void WelcomeDialog::showPopup(void)
// This is a bad way to lock the buttons but it works for now.
if ( scheduled_text.length() <= 2 )
{
- run_from_installer = TRUE;
topButton = popup->addButton(tr("Install or Upgrade "), this,
SLOT(Display_2ndpopup()));
popup->addButton(tr("Run MythFrontend"), this,
diff --git a/abs/core-testing/mythinstall/installsettings.cpp b/abs/core-testing/mythinstall/installsettings.cpp
index 10341db..7315464 100755
--- a/abs/core-testing/mythinstall/installsettings.cpp
+++ b/abs/core-testing/mythinstall/installsettings.cpp
@@ -41,7 +41,7 @@
#include <qsqlquery.h>
#include "mv_common.h"
-int run_from_installer = FALSE;
+int timezone_unknown = FALSE;
extern HostParms hostparm;
extern DDCinfo ddcinfo;
@@ -3403,8 +3403,16 @@ void pre_writesettings ()
hostparm.ThisHostName = "You_Fool";
}
// piece togther the timezone
+ QString tz;
QString tregion;
QString tsubregion;
+
+ tz=gContext->GetSetting("HostTimeZone");
+
+ cout << "tz extracted from database: " << tz << endl;
+ if ( tz.isEmpty() || (tz == "Unknown"))
+ timezone_unknown = TRUE;
+
tregion=gContext->GetSetting("HostTimeZoneRegion");
tsubregion=gContext->GetSetting("HostTimeZoneRegion_"+tregion);
if ( tsubregion.isEmpty() )
@@ -3412,7 +3420,7 @@ void pre_writesettings ()
else
hostparm.ThisTimeZone = tregion + "/" + tsubregion;
- cout << hostparm.ThisTimeZone << endl;
+ cout << "hostparm.ThisTimeZone " << hostparm.ThisTimeZone << endl;
// save some settings back to the datebase
gContext->SaveSetting("HostMyhostname" , hostparm.ThisHostName );
gContext->SaveSetting("HostMysqlserver", hostparm.ThisDBhost );
diff --git a/abs/core-testing/mythinstall/misc_settings.cpp b/abs/core-testing/mythinstall/misc_settings.cpp
index ee09064..7c3eb67 100755
--- a/abs/core-testing/mythinstall/misc_settings.cpp
+++ b/abs/core-testing/mythinstall/misc_settings.cpp
@@ -113,11 +113,18 @@ QString MiscMainFrame::mf_show_tz(QString tz)
QString GTimezone;
int rc;
- autoLaunchTimer->stop();
+ if (autoLaunchTimer->isActive())
+ {
+ autoLaunchTimer->stop();
+
+ // This was triggered by the timer. Only launch the timezone gui if the timezone is unknown.
+ if (!timezone_unknown)
+ return NULL;
+ }
cout << "MiscMainFrame::mf_show_tz " << tz << "\n";
- if ((tz == "") || run_from_installer)
+ if ((tz == "") || timezone_unknown)
tz = "guess";
//launch tzgui and load output into Gtimezone
@@ -152,6 +159,7 @@ QString MiscMainFrame::mf_show_tz(QString tz)
}
file.close();
}
+ timezone_unknown = FALSE;
emit update_timezone(GTimezone);
}
diff --git a/abs/core-testing/mythinstall/mv_common.h b/abs/core-testing/mythinstall/mv_common.h
index 1190a53..865eb3d 100755
--- a/abs/core-testing/mythinstall/mv_common.h
+++ b/abs/core-testing/mythinstall/mv_common.h
@@ -1,4 +1,4 @@
//#define __MVAPP__ MythVantage
#define RELEASEFILE "LinHES-release"
-extern int run_from_installer;
+extern int timezone_unknown;
diff --git a/abs/core-testing/mythinstall/mythinstall b/abs/core-testing/mythinstall/mythinstall
deleted file mode 100755
index 5a7d633..0000000
--- a/abs/core-testing/mythinstall/mythinstall
+++ /dev/null
Binary files differ