summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythgallery/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-01-01 18:25:44 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-01-01 18:25:44 (GMT)
commit6f5a7459a4127507c578cc22b8ae24550a45e123 (patch)
tree3aa68b61ad25846d919751959c7cd4e54ce2ce70 /abs/core-testing/mythtv/old/stable-0.21/mythgallery/PKGBUILD
parent0b90a77e47c10ae4ba815122b0735bc74fba89ea (diff)
downloadlinhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.zip
linhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.tar.gz
linhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.tar.bz2
Cleaning up the tree...
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythgallery/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.21/mythgallery/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythgallery/PKGBUILD b/abs/core-testing/mythtv/old/stable-0.21/mythgallery/PKGBUILD
new file mode 100644
index 0000000..bdf7b57
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythgallery/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <travis@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythgallery
+pkgver=0.21
+pkgrel=5
+pkgdesc="Image gallery plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'libexif' 'libtiff')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins
+ . /etc/profile.d/qt3.sh
+ svn update
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ ./configure --prefix=/usr --disable-all --enable-opengl --enable-mythgallery --enable-exif
+
+ qmake mythplugins.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+
+