summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.21/mythweb/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-01-01 18:25:44 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-01-01 18:25:44 (GMT)
commit6f5a7459a4127507c578cc22b8ae24550a45e123 (patch)
tree3aa68b61ad25846d919751959c7cd4e54ce2ce70 /abs/core-testing/mythtv/old/stable-0.21/mythweb/PKGBUILD
parent0b90a77e47c10ae4ba815122b0735bc74fba89ea (diff)
downloadlinhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.zip
linhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.tar.gz
linhes_pkgbuild-6f5a7459a4127507c578cc22b8ae24550a45e123.tar.bz2
Cleaning up the tree...
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.21/mythweb/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.21/mythweb/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.21/mythweb/PKGBUILD b/abs/core-testing/mythtv/old/stable-0.21/mythweb/PKGBUILD
new file mode 100644
index 0000000..20e9e3d
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.21/mythweb/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=mythweb
+pkgver=0.21
+pkgrel=20
+pkgdesc="Web interface for MythTV's backend"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'lighttpd' 'php' 'local-website')
+install=mythweb.install
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2" wiiweb.tar.bz2 transcoders.patch)
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
+groups=('mythtv-extras')
+DOCROOT=/data/srv/httpd/htdocs/mythweb
+
+build() {
+ cd $startdir/src/mythplugins/mythweb
+ svn update
+ mkdir -p $startdir/pkg/$DOCROOT/{image_cache,php_sessions}
+#apply gallery patches here
+# cd $startdir/src/mythplugins-$pkgver/$pkgname/
+# patch -p0 < $startdir/patch/mythweb_gallery_updated1.diff
+# patch -p2 < $startdir/patch/2923-mythweb-gallery-English_GB_lang.diff
+# tar -zxvf $startdir/patch/icons.tar.gz
+###
+
+ # Workaround for LIGHTTPD bug in mythweb.pl (affects DB queries)
+ cd $startdir/src/mythplugins/$pkgname/
+ patch -p0 < $startdir/patch/mythweb.pl.diff
+ patch -p1 < $startdir/transcoders.patch
+
+ cp -r $startdir/src/mythplugins/$pkgname/* $startdir/pkg/$DOCROOT
+# cp $startdir/src/mythplugins-$pkgver/$pkgname/data/.htaccess $startdir/pkg/$DOCROOT
+ rm $startdir/pkg/srv/$DOCROOT/README
+ tar xjvf $srcdir/wiiweb.tar.bz2 -C $pkgdir/$DOCROOT
+ chown -R http:users $startdir/pkg/$DOCROOT
+ chmod g+rw $startdir/pkg/$DOCROOT/{image_cache,php_sessions,data}
+}
+
+