summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.22/morethemes/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-04-11 08:12:31 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-04-11 08:12:31 (GMT)
commita890cdaf65cc0dbccc39ef0117674b92f12d967f (patch)
treef911bead1de193cd8470e838d360dae2db3098d0 /abs/core-testing/mythtv/old/stable-0.22/morethemes/PKGBUILD
parentf3826493d0230020fd1dae2d30429cd06eac6a2f (diff)
downloadlinhes_pkgbuild-a890cdaf65cc0dbccc39ef0117674b92f12d967f.zip
linhes_pkgbuild-a890cdaf65cc0dbccc39ef0117674b92f12d967f.tar.gz
linhes_pkgbuild-a890cdaf65cc0dbccc39ef0117674b92f12d967f.tar.bz2
MythTV:packaged for mythtv 0.23 and plugins.
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.22/morethemes/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.22/morethemes/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.22/morethemes/PKGBUILD b/abs/core-testing/mythtv/old/stable-0.22/morethemes/PKGBUILD
new file mode 100644
index 0000000..479f886
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.22/morethemes/PKGBUILD
@@ -0,0 +1,51 @@
+pkgname=morethemes
+pkgver=0.22
+pkgrel=22012
+pkgdesc="Additional themes for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv')
+conflicts=('morethemes-svn')
+groups=('mythtv-extras')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+
+_svntrunk=http://cvs.mythtv.org/svn/branches/release-0-22-fixes/themes
+_svnver=23566
+_svnmod=themes
+
+
+build() {
+
+ svn co $_svntrunk --config-dir ./ -r $_svnver $_svnmod
+ svn revert -R $_svnmod
+
+ cd $startdir/src/$_svnmod
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # clean up
+ make distclean
+
+ # configure
+ ./configure --prefix=/usr || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}