summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.22/mp_all.sh
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-04-11 08:12:31 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-04-11 08:12:31 (GMT)
commita890cdaf65cc0dbccc39ef0117674b92f12d967f (patch)
treef911bead1de193cd8470e838d360dae2db3098d0 /abs/core-testing/mythtv/old/stable-0.22/mp_all.sh
parentf3826493d0230020fd1dae2d30429cd06eac6a2f (diff)
downloadlinhes_pkgbuild-a890cdaf65cc0dbccc39ef0117674b92f12d967f.zip
linhes_pkgbuild-a890cdaf65cc0dbccc39ef0117674b92f12d967f.tar.gz
linhes_pkgbuild-a890cdaf65cc0dbccc39ef0117674b92f12d967f.tar.bz2
MythTV:packaged for mythtv 0.23 and plugins.
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.22/mp_all.sh')
-rwxr-xr-xabs/core-testing/mythtv/old/stable-0.22/mp_all.sh33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.22/mp_all.sh b/abs/core-testing/mythtv/old/stable-0.22/mp_all.sh
new file mode 100755
index 0000000..96d5dde
--- /dev/null
+++ b/abs/core-testing/mythtv/old/stable-0.22/mp_all.sh
@@ -0,0 +1,33 @@
+#!/bin/sh
+
+# for 0.22, we are starting the release numbers at 22000
+# and incrementing from there every time we build
+pkgrel=22012
+_svnver=23566
+
+# NOTE: Make sure to build and install mythtv first BEFORE building anything else
+buildlist=('mythtv' 'mytharchive' 'mythbrowser' 'mythflix' 'mythgallery' 'mythgame' 'mythmovies' 'mythmusic' 'mythnews' 'mythvideo' 'mythweather' 'mythzoneminder' 'mythweb' 'myththemes' 'morethemes')
+
+# build and install
+for i in `echo ${buildlist[@]:0}`
+do
+ echo "---------- building $i ----------"
+ cd ./$i
+
+ # set svn version in the PKGBUILD
+ sed -i s/^_svnver=.*/_svnver=$_svnver/ PKGBUILD
+ sed -i s/^pkgrel=.*/pkgrel=$pkgrel/ PKGBUILD
+
+ # make the package
+ mp -f -i -s -r --holdver || exit 1
+
+ # clean up afterwards
+ rm -rf pkg
+ rm -f *~
+
+ cd ..
+done
+
+echo ""
+echo "DONE!"
+