summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/old/stable-0.22/mythweb/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-10-23 18:17:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-10-23 18:19:39 (GMT)
commitadbcf19958300e9b6598990184c8815b945ba0ee (patch)
treef4283c850ac0ac202c17e78a637ee7ca8147621b /abs/core-testing/mythtv/old/stable-0.22/mythweb/PKGBUILD
parent61a68250df10d29b624650948484898334ff22d0 (diff)
downloadlinhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.zip
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.gz
linhes_pkgbuild-adbcf19958300e9b6598990184c8815b945ba0ee.tar.bz2
Removed old core and extra from repo. Renamed -testing to core/extra. This will setup the base for the testing branch.
Diffstat (limited to 'abs/core-testing/mythtv/old/stable-0.22/mythweb/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/old/stable-0.22/mythweb/PKGBUILD50
1 files changed, 0 insertions, 50 deletions
diff --git a/abs/core-testing/mythtv/old/stable-0.22/mythweb/PKGBUILD b/abs/core-testing/mythtv/old/stable-0.22/mythweb/PKGBUILD
deleted file mode 100644
index 060a229..0000000
--- a/abs/core-testing/mythtv/old/stable-0.22/mythweb/PKGBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-pkgname=mythweb
-pkgver=0.22
-pkgrel=22012
-pkgdesc="Web interface for MythTV's backend"
-url="http://www.mythtv.org"
-license="GPL"
-arch=('i686' 'x86_64')
-
-depends=('mythtv' 'lighttpd' 'php' 'local-website' 'perl' 'perl-dbd-mysql' 'perl-math-round')
-conflicts=('mythweb-svn')
-groups=('mythtv-extras')
-install=mythweb.install
-
-patches=()
-source=(`echo ${patches[@]:0}`)
-_svntrunk=http://cvs.mythtv.org/svn/branches/release-0-22-fixes/mythplugins
-_svnver=23566
-_svnmod=mythplugins
-
-DOCROOT=/data/srv/httpd/htdocs/mythweb
-
-build() {
-
- svn co $_svntrunk --config-dir ./ -r $_svnver $_svnmod
- svn revert -R $_svnmod
-
- cd $startdir/src/$_svnmod
-
- echo "--------------------------applying patches----------------------------------------------------"
- for i in `echo ${patches[@]:0} `
- do
- echo applying $i
- echo "-----------------------------"
- patch -Np0 -i ${startdir}/src/$i || return 1
- done
- echo "--------------------------done applying patches-----------------------------------------------"
-
- [ "$CARCH" = "i686" ] && ARCH="i686"
- [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
-
- mkdir -p $startdir/pkg/$DOCROOT/{image_cache,php_sessions}
-
- #cp -r $startdir/src/mythplugins/mythweb/* $startdir/pkg/$DOCROOT
- rsync -arp --exclude .svn --delete-excluded $startdir/src/mythplugins/mythweb/* $startdir/pkg/$DOCROOT
-
- rm $startdir/pkg/$DOCROOT/README
- chown -R http:users $startdir/pkg/$DOCROOT
- chmod g+rw $startdir/pkg/$DOCROOT/{image_cache,php_sessions,data}
-
-}