summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable-0.21/mythgallery
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-12-06 21:05:32 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-12-06 21:05:32 (GMT)
commit105c6ce480c325abee5f4dd4e42296ac769bac84 (patch)
tree8a046eeedcdbb69f9eee9342e4d249df1d773581 /abs/core-testing/mythtv/stable-0.21/mythgallery
parentf9d8baf1e8d94e1252cbd90999d9f2382cff8a57 (diff)
parent7992f86412030fefd007b6509b90d31212ec95f9 (diff)
downloadlinhes_pkgbuild-105c6ce480c325abee5f4dd4e42296ac769bac84.zip
linhes_pkgbuild-105c6ce480c325abee5f4dd4e42296ac769bac84.tar.gz
linhes_pkgbuild-105c6ce480c325abee5f4dd4e42296ac769bac84.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/stable-0.21/mythgallery')
-rw-r--r--abs/core-testing/mythtv/stable-0.21/mythgallery/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable-0.21/mythgallery/PKGBUILD b/abs/core-testing/mythtv/stable-0.21/mythgallery/PKGBUILD
new file mode 100644
index 0000000..bdf7b57
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.21/mythgallery/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <travis@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythgallery
+pkgver=0.21
+pkgrel=5
+pkgdesc="Image gallery plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'libexif' 'libtiff')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins
+ . /etc/profile.d/qt3.sh
+ svn update
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ ./configure --prefix=/usr --disable-all --enable-opengl --enable-mythgallery --enable-exif
+
+ qmake mythplugins.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+
+