summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable-0.21/mythsmolt/PKGBUILD
diff options
context:
space:
mode:
authorUnconfigured <Unconfigured>2009-12-02 21:05:47 (GMT)
committerUnconfigured <Unconfigured>2009-12-02 21:05:47 (GMT)
commitaba971358e17369759ce6fda54870c1496c065e9 (patch)
tree3790afaf7b143ff0b055b6e3758ad7ac01202b97 /abs/core-testing/mythtv/stable-0.21/mythsmolt/PKGBUILD
parent5f484fb1104f638b319ba57e360b25e9445d8291 (diff)
downloadlinhes_pkgbuild-aba971358e17369759ce6fda54870c1496c065e9.zip
linhes_pkgbuild-aba971358e17369759ce6fda54870c1496c065e9.tar.gz
linhes_pkgbuild-aba971358e17369759ce6fda54870c1496c065e9.tar.bz2
mythtv: stable directory renamed to stable-0.21
Diffstat (limited to 'abs/core-testing/mythtv/stable-0.21/mythsmolt/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/stable-0.21/mythsmolt/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable-0.21/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/stable-0.21/mythsmolt/PKGBUILD
new file mode 100644
index 0000000..25c91cf
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.21/mythsmolt/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=mythsmolt
+pkgver=0.21
+pkgrel=8
+pkgdesc="mythsmolt, a hardware profileing tool"
+arch=('i686' 'x86_64')
+url="http://www.mythvantage.com"
+license=('GPL')
+depends=("mythtv>=${pkgver}" urlgrabber)
+source=("http://www.mythvantage.com/request.php?4")
+
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythsmolt_src/mythsmolt
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ echo "INCLUDEPATH += /usr/include/mythtv" >> mythsmolt.pro.usr
+
+ qmake mythsmolt.pro.usr
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}