summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable-0.22
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-03-29 23:37:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-03-29 23:37:14 (GMT)
commit7cfb5b2b2731f9b05f0490ae2e4ee828788b6347 (patch)
treeca247c37a7ea435efb896ff329e098032dba141c /abs/core-testing/mythtv/stable-0.22
parent338a478507e9c1c535fb149b04cc81000627c340 (diff)
downloadlinhes_pkgbuild-7cfb5b2b2731f9b05f0490ae2e4ee828788b6347.zip
linhes_pkgbuild-7cfb5b2b2731f9b05f0490ae2e4ee828788b6347.tar.gz
linhes_pkgbuild-7cfb5b2b2731f9b05f0490ae2e4ee828788b6347.tar.bz2
mythsmolt: This is fix for the smolt prompt on logout, and the opening of any bash shell that my last smolt commit caused.
Diffstat (limited to 'abs/core-testing/mythtv/stable-0.22')
-rw-r--r--abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD4
-rw-r--r--abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh47
2 files changed, 33 insertions, 18 deletions
diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
index 42674dd..d970cd9 100644
--- a/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythsmolt
pkgver=0.22
-pkgrel=17
+pkgrel=26
pkgdesc="mythsmolt, a hardware profileing tool"
arch=('i686' 'x86_64')
url="http://www.mythvantage.com"
@@ -18,4 +18,4 @@ build() {
install -D -m 755 $srcdir/smolt_init_login.sh $pkgdir/etc/profile.d/smolt_init_login.sh
}
md5sums=('fdf68ec5c78827aefca6f09ad82296a4'
- 'c6789befd70278a453dc6be73ed240e7')
+ '57a3416d90e59abbd5062436583c17e1')
diff --git a/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
index f22a09e..0b76305 100644
--- a/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
+++ b/abs/core-testing/mythtv/stable-0.22/mythsmolt/smolt_init_login.sh
@@ -1,24 +1,39 @@
if [ $UID = 0 -o $UID = 1000 ]
then
- if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+ INIT=`ps -p 1 -o comm=`
+ if [ x$INIT = xrunit ]
then
- echo ""
- echo "####################################################"
- echo "It appears you have not yet run smolt"
- echo "Please take the time to submit your hardware profile"
- echo ""
- echo "press any key to continue:"
- echo "####################################################"
- read a
- if [ $UID = 0 ]
+ if [[ -f /home/mythtv/.configure && $- = *i* ]]
then
- su mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py"
- su mythtv -c "touch /home/mythtv/.mythtv/MythSmolt/hw-uuid"
- else
- /usr/share/mythtv/mythsmolt/scripts/sendProfile.py
- touch /home/mythtv/.mythtv/MythSmolt/hw-uuid
+ if [ ! -z "$PS1" ]
+ then
+ if [ $0 = "-bash" ]
+ then
+ if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+ then
+ echo ""
+ echo "####################################################"
+ echo "It appears you have not yet run smolt"
+ echo "Please take the time to submit your hardware profile"
+ echo ""
+ echo "press any key to continue:"
+ echo "####################################################"
+ read a
+ mkdir -p /home/mythtv/.mythtv/MythSmolt
+ chown -R mythtv:users /home/mythtv/.mythtv/MythSmolt
+
+ if [ $UID = 0 ]
+ then
+ su mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py" && su mythtv -c "touch /home/mythtv/.mythtv/MythSmolt/hw-uuid"
+ else
+ /usr/share/mythtv/mythsmolt/scripts/sendProfile.py && touch /home/mythtv/.mythtv/MythSmolt/hw-uuid
+ fi
+ fi
+ fi
+ fi
fi
-
fi
fi
+
+