summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable-0.23/mythsmolt/smolt_init_login.sh
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verison.net>2010-05-28 01:24:03 (GMT)
committerMichael Hanson <hansonorders@verison.net>2010-05-28 01:24:03 (GMT)
commit2eaf92317ce1ebd43f3d660a44c601e4e8c47f26 (patch)
tree865e2c9f638d582e04204b2709a0ffd2c3763b7d /abs/core-testing/mythtv/stable-0.23/mythsmolt/smolt_init_login.sh
parent68c43cc7e97ac4a37ab25565869bee0647f9546f (diff)
parentb3f688197171eaae883a3d9d2d7b17237b1ae775 (diff)
downloadlinhes_pkgbuild-2eaf92317ce1ebd43f3d660a44c601e4e8c47f26.zip
linhes_pkgbuild-2eaf92317ce1ebd43f3d660a44c601e4e8c47f26.tar.gz
linhes_pkgbuild-2eaf92317ce1ebd43f3d660a44c601e4e8c47f26.tar.bz2
Merge branch 'master' of mihanson@knoppmyth.net:LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/stable-0.23/mythsmolt/smolt_init_login.sh')
-rw-r--r--abs/core-testing/mythtv/stable-0.23/mythsmolt/smolt_init_login.sh39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable-0.23/mythsmolt/smolt_init_login.sh b/abs/core-testing/mythtv/stable-0.23/mythsmolt/smolt_init_login.sh
new file mode 100644
index 0000000..0b76305
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.23/mythsmolt/smolt_init_login.sh
@@ -0,0 +1,39 @@
+if [ $UID = 0 -o $UID = 1000 ]
+then
+ INIT=`ps -p 1 -o comm=`
+ if [ x$INIT = xrunit ]
+ then
+ if [[ -f /home/mythtv/.configure && $- = *i* ]]
+ then
+ if [ ! -z "$PS1" ]
+ then
+ if [ $0 = "-bash" ]
+ then
+ if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+ then
+ echo ""
+ echo "####################################################"
+ echo "It appears you have not yet run smolt"
+ echo "Please take the time to submit your hardware profile"
+ echo ""
+ echo "press any key to continue:"
+ echo "####################################################"
+ read a
+ mkdir -p /home/mythtv/.mythtv/MythSmolt
+ chown -R mythtv:users /home/mythtv/.mythtv/MythSmolt
+
+ if [ $UID = 0 ]
+ then
+ su mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py" && su mythtv -c "touch /home/mythtv/.mythtv/MythSmolt/hw-uuid"
+ else
+ /usr/share/mythtv/mythsmolt/scripts/sendProfile.py && touch /home/mythtv/.mythtv/MythSmolt/hw-uuid
+ fi
+ fi
+ fi
+ fi
+ fi
+ fi
+fi
+
+
+