summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable-0.23/mythtv
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-21 04:33:39 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-21 04:33:39 (GMT)
commitd6b062b995922586a39e1d320779ce459002ee9c (patch)
tree56eefcc98adb725f76dd461fe479271eee4b20aa /abs/core-testing/mythtv/stable-0.23/mythtv
parent79b3ed9852a1d7614902ef746a9234336c9e014a (diff)
downloadlinhes_pkgbuild-d6b062b995922586a39e1d320779ce459002ee9c.zip
linhes_pkgbuild-d6b062b995922586a39e1d320779ce459002ee9c.tar.gz
linhes_pkgbuild-d6b062b995922586a39e1d320779ce459002ee9c.tar.bz2
mythtv: edited to work, removed sourceing the profile as it seemed to abort the process
Diffstat (limited to 'abs/core-testing/mythtv/stable-0.23/mythtv')
-rwxr-xr-xabs/core-testing/mythtv/stable-0.23/mythtv/PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/abs/core-testing/mythtv/stable-0.23/mythtv/PKGBUILD b/abs/core-testing/mythtv/stable-0.23/mythtv/PKGBUILD
index a3420b5..3854417 100755
--- a/abs/core-testing/mythtv/stable-0.23/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.23/mythtv/PKGBUILD
@@ -46,28 +46,34 @@ build() {
[ "$CARCH" = "x86_64" ] && ARCH="x86-64"
# clean up from last build
+ echo " simple configure to makesure the distclean works"
+ ./configure
make distclean
-
# configure
- ./configure --prefix=/usr --arch=${ARCH} \
+ #./configure --prefix=/usr --arch=${ARCH} \
+ echo "our configure"
+ ./configure --prefix=/usr \
--enable-vdpau --enable-xvmc --enable-xvmc-pro \
--enable-opengl-vsync --enable-libfaad --enable-dvb --enable-firewire \
--compile-type=release --with-bindings=perl,python \
- --enable-audio-alsa --disable-audio-jack --disable-audio-pulseoutput || return 1
-
+ --enable-audio-alsa --disable-audio-jack --disable-audio-pulseoutput
+ #--enable-audio-alsa --disable-audio-jack --disable-audio-pulseoutput || return 1
+ echo "post configure"
# build and install
- . /etc/profile
+ #. /etc/profile
+ echo "post profile"
make || return 1
+ echo "post make"
make INSTALL_ROOT=$startdir/pkg install || return 1
# install db schema, scripts and docs
install -m0644 database/mc.sql $startdir/pkg/usr/share/mythtv/ || return 1
install -D -m0755 ../mythbackend $startdir/pkg/etc/rc.d/mythbackend || return 1
# cp -r docs $startdir/pkg/usr/share/mythtv/ || return 1
- rsync -arp --exclude .svn --delete-excluded docs $startdir/pkg/usr/share/mythtv/ || return 1
+ rsync -arp --exclude .svn --delete-excluded docs $startdir/pkg/usr/share/mythtv/ || return 1
# install contrib
- rsync -arp --exclude .svn --delete-excluded contrib $startdir/pkg/usr/share/mythtv/ || return 1
+ rsync -arp --exclude .svn --delete-excluded contrib $startdir/pkg/usr/share/mythtv/ || return 1
#cp -r contrib $startdir/pkg/usr/share/mythtv/ || return 1
# patch the xml LinHES style