summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable.22/mythweather/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-11-13 06:38:57 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-11-13 06:38:57 (GMT)
commit8c91f3da4388f832a841e4a86bd53273ca45ead8 (patch)
tree9a04455c1f59193fbe0e346a1881de1f4b24272d /abs/core-testing/mythtv/stable.22/mythweather/PKGBUILD
parent9c2a170ff71e556da1c40ad5d1162fc3fdb7de39 (diff)
downloadlinhes_pkgbuild-8c91f3da4388f832a841e4a86bd53273ca45ead8.zip
linhes_pkgbuild-8c91f3da4388f832a841e4a86bd53273ca45ead8.tar.gz
linhes_pkgbuild-8c91f3da4388f832a841e4a86bd53273ca45ead8.tar.bz2
mythtv.22: copy svn pkgbuilds to stable.22. This is to prepare .22 packages so -svn can continue tracking trunk.
As of right now their only purpose is to have something to build mythvantage against.
Diffstat (limited to 'abs/core-testing/mythtv/stable.22/mythweather/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/stable.22/mythweather/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable.22/mythweather/PKGBUILD b/abs/core-testing/mythtv/stable.22/mythweather/PKGBUILD
new file mode 100644
index 0000000..f3a45e5
--- /dev/null
+++ b/abs/core-testing/mythtv/stable.22/mythweather/PKGBUILD
@@ -0,0 +1,51 @@
+pkgname=mythweather-svn
+pkgver=22783
+pkgrel=1
+pkgdesc="Weather checking plugin for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'wget')
+conflicts=('mythweather')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+_svntrunk=http://cvs.mythtv.org/svn/branches/release-0-22-fixes/mythplugins
+#_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn revert -R $_svnmod
+
+ cd $startdir/src/$_svnmod
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # clean up
+ make distclean
+
+ # configure
+ ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+ --enable-mythweather || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}