summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable/mythstream/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-26 02:27:23 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-26 02:27:23 (GMT)
commit53f57020ae0e9adeb2d650a58b5e21806f48602b (patch)
tree7f9ab58de6cef696f800a28ed971df2f382ab0ac /abs/core-testing/mythtv/stable/mythstream/PKGBUILD
parent1998cc06c2ed1547c75843c882b3940bcee3f303 (diff)
downloadlinhes_pkgbuild-53f57020ae0e9adeb2d650a58b5e21806f48602b.zip
linhes_pkgbuild-53f57020ae0e9adeb2d650a58b5e21806f48602b.tar.gz
linhes_pkgbuild-53f57020ae0e9adeb2d650a58b5e21806f48602b.tar.bz2
Initial MythStream build for LinHES.
Diffstat (limited to 'abs/core-testing/mythtv/stable/mythstream/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/stable/mythstream/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable/mythstream/PKGBUILD b/abs/core-testing/mythtv/stable/mythstream/PKGBUILD
new file mode 100644
index 0000000..e78ecee
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythstream/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythstream
+pkgver=0.18_1
+pkgrel=2
+pkgdesc="Unofficial MythTV plugin for Internet audio and video streams."
+arch=('i686' 'x86_64')
+url="http://home.kabelfoon.nl/~moongies/streamtuned.html"
+license=('GPL')
+depends=('mythtv' 'perl-xml-simple')
+source=("http://home.kabelfoon.nl/~moongies/sw9vc4htz2/mythstream-v0.18_1.tar.gz" "http://home.kabelfoon.nl/~moongies/sw9vc4htz2/mythstream.cpp.patch_svn20071123")
+md5sums=('')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythstream-0.18_1
+ ln -s ../../../mythtv/src/mythtv-0.21/libs/lib* .
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+
+ qmake mythstream.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+