summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-08 22:20:20 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-08 22:20:20 (GMT)
commitd2cbfc286c25f31f20433e9149a0e62c4aaf900f (patch)
treedf940ae978797d62f346f465b91736b45d096649 /abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
parent7ee47af1a90327ecdd7ff9d790f2022545366b55 (diff)
downloadlinhes_pkgbuild-d2cbfc286c25f31f20433e9149a0e62c4aaf900f.zip
linhes_pkgbuild-d2cbfc286c25f31f20433e9149a0e62c4aaf900f.tar.gz
linhes_pkgbuild-d2cbfc286c25f31f20433e9149a0e62c4aaf900f.tar.bz2
The new structure... does not work yet.
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD b/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
new file mode 100644
index 0000000..4c57cf0
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/mythbrowser/PKGBUILD
@@ -0,0 +1,35 @@
+
+pkgname=mythbrowser-svn
+pkgver=16153
+pkgrel=2
+pkgdesc="Mini web browser for MythTV"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-svn' 'wget' 'libxvmc' 'kdelibs')
+conflicts=('mythtv-plugins-svn')
+groups=('mythtv-all-plugins-svn')
+license="GPL"
+source=()
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ pwd
+ PLUGIN=mythbrowser
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ make distclean
+ ./configure --enable-opengl --disable-all --enable-mythbrowser || return 1
+ # sed -i 's#kde3#kde#' ./mythbrowser/mythbrowser/Makefile || return 1
+ make || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}