summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-18 21:53:30 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-18 21:53:30 (GMT)
commit0768fd247ab83931c94fde0901abdbacfe5113ab (patch)
treed605ab262a99e7dd32c00301187653347086d6ce /abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
parent01ae00b3779f3319f00ef33398232603ed22d30e (diff)
downloadlinhes_pkgbuild-0768fd247ab83931c94fde0901abdbacfe5113ab.zip
linhes_pkgbuild-0768fd247ab83931c94fde0901abdbacfe5113ab.tar.gz
linhes_pkgbuild-0768fd247ab83931c94fde0901abdbacfe5113ab.tar.bz2
builds fine, but not tested
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD63
1 files changed, 37 insertions, 26 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
index 52fb732..339ed35 100644
--- a/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
@@ -1,36 +1,47 @@
pkgname=mythgallery-svn
-pkgver=16153
-pkgrel=3
+pkgver=20018
+pkgrel=1
pkgdesc="Image gallery plugin for MythTV"
url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn' 'libexif' 'libtiff')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
license="GPL"
-source=()
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'libexif' 'libtiff')
+conflicts=('mythgallery')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
_svnmod=mythplugins
build() {
- cd $startdir/src/
- echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- cd $startdir/src/mythplugins
- export QMAKESPEC='linux-g++'
- PLUGIN=mythgallery
- grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
- if [ $? != 0 ]
- then
- echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
- msg "appending program lib"
- fi
- make distclean
- ./configure --disable-all --enable-opengl --enable-mythgallery --enable-exif
-
- make -j 2 || return 1
-
- make INSTALL_ROOT=$startdir/pkg install
-}
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+# svn co $_svntrunk --config-dir ./ $_svnmod
+
+ cd $startdir/src/$_svnmod
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # configure
+ ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+ --enable-mythgallery || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}