summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythmovies
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-19 21:45:41 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-19 21:45:41 (GMT)
commit2a4fa579c512741d1699ba305caa84f5495ed6c3 (patch)
treed16dce31b834aec4d99d543335122a759671029b /abs/core-testing/mythtv/trunk/mythmovies
parent3c44e21952160c5e469078ab06539bba4d1b238d (diff)
downloadlinhes_pkgbuild-2a4fa579c512741d1699ba305caa84f5495ed6c3.zip
linhes_pkgbuild-2a4fa579c512741d1699ba305caa84f5495ed6c3.tar.gz
linhes_pkgbuild-2a4fa579c512741d1699ba305caa84f5495ed6c3.tar.bz2
builds fine, but not tested
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythmovies')
-rw-r--r--abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
new file mode 100644
index 0000000..341cf55
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/mythmovies/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=mythmovies-svn
+pkgver=20019
+pkgrel=1
+pkgdesc="Displays information about movies playing in the area."
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn')
+conflicts=('mythmovies')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+# svn co $_svntrunk --config-dir ./ $_svnmod
+
+ cd $startdir/src/$_svnmod
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # configure
+ ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+ --enable-mythmovies || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}