summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythnetvision/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-01-23 09:52:57 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-01-23 09:52:57 (GMT)
commitcff9d113ea9ebe768ce84dc0165c54bd58a083b1 (patch)
treeac291454b14f1e269e8b0c932f95b05d2ab13570 /abs/core-testing/mythtv/trunk/mythnetvision/PKGBUILD
parent332702fe9eaf2db10c7bc2fdf840460e9c119623 (diff)
parent14f51217ce88a654aff4a41b8cea7b05185537ae (diff)
downloadlinhes_pkgbuild-cff9d113ea9ebe768ce84dc0165c54bd58a083b1.zip
linhes_pkgbuild-cff9d113ea9ebe768ce84dc0165c54bd58a083b1.tar.gz
linhes_pkgbuild-cff9d113ea9ebe768ce84dc0165c54bd58a083b1.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythnetvision/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/mythnetvision/PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythnetvision/PKGBUILD b/abs/core-testing/mythtv/trunk/mythnetvision/PKGBUILD
new file mode 100644
index 0000000..203b89c
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/mythnetvision/PKGBUILD
@@ -0,0 +1,51 @@
+pkgname=mythnetvision-svn
+pkgver=23190
+pkgrel=1
+pkgdesc="Internet video plugin for MythTV"
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn')
+conflicts=('mythnetvision')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
+
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn revert -R $_svnmod
+
+ cd $startdir/src/$_svnmod
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # clean up
+ make distclean
+
+ # configure
+ ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+ --enable-mythnetvision || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}