summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-17 16:46:53 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-17 16:46:53 (GMT)
commit9d327823ebe603376dce4001876c25149c388c8d (patch)
treec93c907c60fd0a301e4465c0945b7b1a09eed2f9 /abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
parentcdc9423cc94f4936a776d845d89fad10a64bb5f4 (diff)
downloadlinhes_pkgbuild-9d327823ebe603376dce4001876c25149c388c8d.zip
linhes_pkgbuild-9d327823ebe603376dce4001876c25149c388c8d.tar.gz
linhes_pkgbuild-9d327823ebe603376dce4001876c25149c388c8d.tar.bz2
finally works. not fully testing.
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythtv/PKGBUILD')
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 056a99e..4277f16 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -1,22 +1,24 @@
pkgname=mythtv-svn
pkgver=19974
-pkgrel=1
+pkgrel=3
pkgdesc="A personal video recorder for Linux"
url="http://www.mythtv.org"
license="GPL"
-depends=('lame' 'libmysqlclient' 'alsa-lib' 'wget' 'qt' 'x-server' 'freetype2' 'libmpeg2' 'libxml2' 'libraw1394' 'lirc' 'perl-date-manip' 'libavc1394' 'libdc1394' 'libiec61883')
-makedepends=('subversion')
-conflicts=(mythtv)
+depends=('bash' 'mysql-clients>=5.0' 'qt' 'lame' 'lirc-utils' 'ffmpeg' \
+ 'faad2' 'libxv' 'libxvmc' 'libavc1394' 'libdc1394' 'libiec61883')
+makedepends=('libgl' 'subversion')
+conflicts=('mythtv')
replaces=()
+groups=('pvr')
backup=()
-options=(!strip)
-MAKEFLAGS="-j6"
+#options=(!strip)
+#MAKEFLAGS="-j6"
install='mythtv.install'
patchs=('smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch' 'mpegrecorder-hdpvr-v2a.patch' 'hdpvr-livetv.patch')
#patchs=('svn_main_menu_popup.patch' 'smolt_jump.patch' 'DeviceReadBuffer-polltimeout.2.patch' 'mpegrecorder-hdpvr-v2a.patch' 'hdpvr-livetv.patch')
source=('mythbackend' 'myth.sh' `echo ${patchs[@]:0}` )
-arch=('i686')
+arch=('i686' 'x86_64')
md5sums=()
_svntrunk=http://cvs.mythtv.org/svn/trunk/mythtv
@@ -46,7 +48,7 @@ build() {
# configure
./configure --prefix=/usr --cpu=${ARCH} \
--enable-vdpau --enable-xvmc --enable-xvmc-pro \
- --enable-opengl-vsync --enable-libfaad --enable-dvb --enable-firewire \
+ --enable-opengl-vsync --enable-libfaad --enable-dvb --disable-firewire \
--compile-type=release --with-bindings=perl,python \
--enable-audio-alsa --disable-audio-jack --disable-audio-arts || return 1