summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythtv
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-08 22:57:00 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-08 22:57:00 (GMT)
commit63f9cc27578f48982a7e334e40a2db95f2ec3dca (patch)
treecb7dd7b39cc4a038b03f42637eb3bb5f587a5abe /abs/core-testing/mythtv/trunk/mythtv
parentd2cbfc286c25f31f20433e9149a0e62c4aaf900f (diff)
downloadlinhes_pkgbuild-63f9cc27578f48982a7e334e40a2db95f2ec3dca.zip
linhes_pkgbuild-63f9cc27578f48982a7e334e40a2db95f2ec3dca.tar.gz
linhes_pkgbuild-63f9cc27578f48982a7e334e40a2db95f2ec3dca.tar.bz2
Finally compiles, but patches are not clean yet.
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythtv')
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index d5560bd..56929a7 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mythtv-svn
-pkgver=19295
+pkgver=19957
pkgrel=1
pkgdesc="A personal video recorder for Linux"
url="http://www.mythtv.org"
@@ -23,8 +23,9 @@ _svnmod=mythtv
build() {
-# svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+# svn co $_svntrunk --config-dir ./ $_svnmod
+
cd $startdir/src/mythtv
echo "--------------------------applying patches----------------------------------------------------"
@@ -37,7 +38,9 @@ build() {
echo "--------------------------done applying patches-----------------------------------------------"
sed -i -e "s/\`(svnversion \$\${SVNTREEDIR} 2>\/dev\/null) || echo Unknown\`/$pkgver/" version.pro
- make distclean
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
# configure
./configure --prefix=/usr --cpu=${ARCH} \