summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-02-20 19:55:13 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-02-20 19:55:13 (GMT)
commitf1aa9caeafea56ab0680d96992bfbf2dc4f2a55e (patch)
tree1c81c16a33bbd7d10b2fcc9aa46265eb7c58406d /abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
parent4fb9b4e5fbf9dbf9d4ed494318a27116dd17d8e1 (diff)
downloadlinhes_pkgbuild-f1aa9caeafea56ab0680d96992bfbf2dc4f2a55e.zip
linhes_pkgbuild-f1aa9caeafea56ab0680d96992bfbf2dc4f2a55e.tar.gz
linhes_pkgbuild-f1aa9caeafea56ab0680d96992bfbf2dc4f2a55e.tar.bz2
builds fine, but not tested
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythweather/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/mythweather/PKGBUILD62
1 files changed, 37 insertions, 25 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
index 98542b9..02034d4 100644
--- a/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythweather/PKGBUILD
@@ -1,35 +1,47 @@
pkgname=mythweather-svn
-pkgver=16153
-pkgrel=6
+pkgver=20019
+pkgrel=1
pkgdesc="Weather checking plugin for MythTV"
url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn' 'wget' 'perl-xml-sax' 'perl-soap-lite' 'perl-image-size' 'imagemagick')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
license="GPL"
-source=()
+arch=('i686' 'x86_64')
+
+depends=('mythtv-svn' 'wget')
+conflicts=('mythweather')
+groups=('mythtv-extras-svn')
+
+patches=()
+source=(`echo ${patches[@]:0}`)
_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
_svnmod=mythplugins
build() {
- cd $startdir/src/
- echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- cd $startdir/src/mythplugins
- make distclean
- PLUGIN=mythweather
- grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
- if [ $? != 0 ]
- then
- echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
- msg "appending program lib"
- fi
- ./configure --enable-opengl --disable-all --enable-mythweather
-
- make -j 2 || return 1
-
- make INSTALL_ROOT=$startdir/pkg install
+
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+# svn co $_svntrunk --config-dir ./ $_svnmod
+
+ cd $startdir/src/$_svnmod
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # configure
+ ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+ --enable-mythweather || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
}
-md5sums=('2a9fbf45ae58a3a35857ce8d7c4d12db')