summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-class-singleton
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-03-22 22:10:53 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-03-22 22:10:53 (GMT)
commitfcc27b022b55e98ef9053c33501b7173fc193d55 (patch)
tree1f57cfc2c0c6a5fbad619175c73dc6c2ebc56112 /abs/core-testing/perl_modules/perl-class-singleton
parentbb605e913399be9c67bd063e49103663033f55e1 (diff)
downloadlinhes_pkgbuild-fcc27b022b55e98ef9053c33501b7173fc193d55.zip
linhes_pkgbuild-fcc27b022b55e98ef9053c33501b7173fc193d55.tar.gz
linhes_pkgbuild-fcc27b022b55e98ef9053c33501b7173fc193d55.tar.bz2
Various modules need for Shepherd.
Diffstat (limited to 'abs/core-testing/perl_modules/perl-class-singleton')
-rw-r--r--abs/core-testing/perl_modules/perl-class-singleton/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-class-singleton/PKGBUILD b/abs/core-testing/perl_modules/perl-class-singleton/PKGBUILD
new file mode 100644
index 0000000..60f71b9
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-class-singleton/PKGBUILD
@@ -0,0 +1,23 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: François Charette <firmicus ατ gmx δοτ net>
+
+pkgname=perl-class-singleton
+pkgver=1.4
+pkgrel=2
+pkgdesc="Implementation of a "Singleton" class"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~ABW/Class-Singleton"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/A/AB/ABW/Class-Singleton-$pkgver.tar.gz)
+md5sums=('a18b108ab97e2107cbbe816d2b3e2ee3')
+
+build() {
+ cd $startdir/src/Class-Singleton-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}