summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-datetime-format-iso8601/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2010-08-15 06:53:50 (GMT)
committerBritney Fransen <brfransen@gmail.com>2010-08-15 06:53:50 (GMT)
commitf88720aea343f25dee859998224c7e341fe703b7 (patch)
treeaa398c077d5e3a8d59411f7de4ae0dc997aa7a42 /abs/core-testing/perl_modules/perl-datetime-format-iso8601/PKGBUILD
parentc15a5824669c3cd87f150ba04fa9e21d6db75318 (diff)
downloadlinhes_pkgbuild-f88720aea343f25dee859998224c7e341fe703b7.zip
linhes_pkgbuild-f88720aea343f25dee859998224c7e341fe703b7.tar.gz
linhes_pkgbuild-f88720aea343f25dee859998224c7e341fe703b7.tar.bz2
perl-modules: add more perl modules. refs#712
Diffstat (limited to 'abs/core-testing/perl_modules/perl-datetime-format-iso8601/PKGBUILD')
-rw-r--r--abs/core-testing/perl_modules/perl-datetime-format-iso8601/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-datetime-format-iso8601/PKGBUILD b/abs/core-testing/perl_modules/perl-datetime-format-iso8601/PKGBUILD
new file mode 100644
index 0000000..360b88a
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-datetime-format-iso8601/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Lukas Fleischer <archlinux at cryptocrack dot de>
+
+pkgname=perl-datetime-format-iso8601
+pkgver=0.07
+pkgrel=1
+pkgdesc="Parses ISO8601 formats."
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/dist/DateTime-Format-ISO8601/"
+license=('PerlArtistic')
+depends=('perl-datetime-format-builder>=0.770.0' 'perl-datetime>=0.18')
+#makedepends=('perl-module-build>=0.350.0')
+optdepends=('perl-file-find-rule'
+ 'perl-test-distribution'
+ 'perl-test-pod')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/J/JH/JHOBLITT/DateTime-Format-ISO8601-$pkgver.tar.gz")
+md5sums=('debb51180d0318ae09cad01c544a1d7d')
+
+build() {
+ cd $srcdir/DateTime-Format-ISO8601-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR="${pkgdir}" || return 1
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}