summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-image-size/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 17:30:51 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 17:30:51 (GMT)
commit562074d2036106b5cd46505fe9823c939c1e7ff1 (patch)
tree3571a47cb625390715acf760b4489fe1b1629bab /abs/core-testing/perl_modules/perl-image-size/PKGBUILD
parent6d04d899f89686ea784fab07c5a0f5090556e64d (diff)
downloadlinhes_pkgbuild-562074d2036106b5cd46505fe9823c939c1e7ff1.zip
linhes_pkgbuild-562074d2036106b5cd46505fe9823c939c1e7ff1.tar.gz
linhes_pkgbuild-562074d2036106b5cd46505fe9823c939c1e7ff1.tar.bz2
Add a few more perl modules required for other programs.
Diffstat (limited to 'abs/core-testing/perl_modules/perl-image-size/PKGBUILD')
-rw-r--r--abs/core-testing/perl_modules/perl-image-size/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-image-size/PKGBUILD b/abs/core-testing/perl_modules/perl-image-size/PKGBUILD
new file mode 100644
index 0000000..4b3d0d4
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-image-size/PKGBUILD
@@ -0,0 +1,24 @@
+# This PKGBUILD was autocreated. See http://xtermin.us/archperl/ for details
+# Maintainer: Charles Mauch <cmauch@gmail.com>
+pkgname=perl-image-size
+pkgver=3.1
+pkgrel=2
+pkgdesc="Perl/CPAN Module XML::Parser : Flexible fast parser with plugin styles"
+arch=("i686" "x86_64")
+url="http://search.cpan.org/MSERGEANT/XML-Parser"
+license=("GPL" "Artistic")
+source=("http://search.cpan.org/CPAN/authors/id/R/RJ/RJRAY/Image-Size-3.1.tar.gz")
+
+build() {
+ cd $startdir/src/Image-Size-3.1
+ eval `perl -V:archname`
+ /usr/bin/perl Makefile.PL \
+ INSTALLARCHLIB=/usr/lib/perl5/current/${archname} \
+ INSTALLSITELIB=/usr/lib/perl5/site_perl/current \
+ INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${archname} || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -exec rm '{}' \; && \
+ /usr/bin/find $startdir/pkg -name 'perllocal.pod' -exec rm '{}' \; && \
+ /usr/bin/find $startdir/pkg -depth -type d -empty -exec rmdir '{}' \;
+}