summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-x10/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-19 15:22:40 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-19 15:22:40 (GMT)
commiteaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b (patch)
tree1039b920717da374ee67975622724f17f6fe89e1 /abs/core-testing/perl_modules/perl-x10/PKGBUILD
parente7d7822ab75eeb5b35fd7ee6d9a1cfc4e730272e (diff)
parent6f90626a0bf289be8f0497fd6b135c7ef831e0fd (diff)
downloadlinhes_pkgbuild-eaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b.zip
linhes_pkgbuild-eaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b.tar.gz
linhes_pkgbuild-eaa1e24dfe16f3f5a3d12b194f977e971c8f4b4b.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing/perl_modules/perl-x10/PKGBUILD')
-rw-r--r--abs/core-testing/perl_modules/perl-x10/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-x10/PKGBUILD b/abs/core-testing/perl_modules/perl-x10/PKGBUILD
new file mode 100644
index 0000000..51283d5
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-x10/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-x10
+pkgver=0.03
+pkgrel=2
+pkgdesc="X10"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~ROBF/X10"
+license=('GPL' 'PerlArtistic')
+depends=('perl-astro-suntime>=0.01' 'perl-device-serialport' 'perl-time-modules')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/R/RO/ROBF/X10-$pkgver.tar.gz)
+md5sums=('056b3d98fab545865148b948de6784c7')
+
+build() {
+ cd $startdir/src/X10-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: