summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-19 08:00:36 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-19 08:00:36 (GMT)
commit6f90626a0bf289be8f0497fd6b135c7ef831e0fd (patch)
treea6bb8ed23d252765f1a7888ed079ec156cd68e81 /abs/core-testing/perl_modules
parent100915fd681da7bd7d56311c6f866003d88e6141 (diff)
downloadlinhes_pkgbuild-6f90626a0bf289be8f0497fd6b135c7ef831e0fd.zip
linhes_pkgbuild-6f90626a0bf289be8f0497fd6b135c7ef831e0fd.tar.gz
linhes_pkgbuild-6f90626a0bf289be8f0497fd6b135c7ef831e0fd.tar.bz2
MythZoneMinder, ZoneMinder and deps.
Diffstat (limited to 'abs/core-testing/perl_modules')
-rw-r--r--abs/core-testing/perl_modules/perl-astro-suntime/PKGBUILD29
-rw-r--r--abs/core-testing/perl_modules/perl-device-serialport/PKGBUILD29
-rw-r--r--abs/core-testing/perl_modules/perl-php-serialization/PKGBUILD30
-rw-r--r--abs/core-testing/perl_modules/perl-test-pod/PKGBUILD25
-rw-r--r--abs/core-testing/perl_modules/perl-time-modules/PKGBUILD25
-rw-r--r--abs/core-testing/perl_modules/perl-unicode-map/PKGBUILD30
-rw-r--r--abs/core-testing/perl_modules/perl-x10/PKGBUILD30
7 files changed, 198 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-astro-suntime/PKGBUILD b/abs/core-testing/perl_modules/perl-astro-suntime/PKGBUILD
new file mode 100644
index 0000000..d615aa3
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-astro-suntime/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-astro-suntime
+pkgver=0.01
+pkgrel=2
+pkgdesc="Calculate sun rise/set times"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~ROBF/Astro-SunTime"
+license=('GPL' 'PerlArtistic')
+depends=('perl-time-modules')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz)
+md5sums=('4657927a49604494bfaaa153663b90b9')
+
+build() {
+ cd $startdir/src/Astro-SunTime-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/perl_modules/perl-device-serialport/PKGBUILD b/abs/core-testing/perl_modules/perl-device-serialport/PKGBUILD
new file mode 100644
index 0000000..d1341c8
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-device-serialport/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-device-serialport
+pkgver=1.04
+pkgrel=2
+pkgdesc="POSIX clone of Win32::SerialPort"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~COOK/Device-SerialPort"
+license=('GPL' 'PerlArtistic')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/C/CO/COOK/Device-SerialPort-$pkgver.tar.gz)
+md5sums=('82c698151f934eb28c65d1838cee7d9e')
+
+build() {
+ cd $startdir/src/Device-SerialPort-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/perl_modules/perl-php-serialization/PKGBUILD b/abs/core-testing/perl_modules/perl-php-serialization/PKGBUILD
new file mode 100644
index 0000000..428ee8e
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-php-serialization/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-php-serialization
+pkgver=0.27
+pkgrel=2
+pkgdesc="PHP::Serialization"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~php-serialization/PHP-Serialization"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/J/JB/JBROWN/php-serialization/PHP-Serialization-$pkgver.tar.gz)
+md5sums=('2fb3f63071c5c2119b4eebe39b329684')
+
+build() {
+ cd $startdir/src/PHP-Serialization-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/perl_modules/perl-test-pod/PKGBUILD b/abs/core-testing/perl_modules/perl-test-pod/PKGBUILD
new file mode 100644
index 0000000..a901b02
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-test-pod/PKGBUILD
@@ -0,0 +1,25 @@
+#
+# Contributor: Oliver Charles <oliver.g.charles@googlemail.com>
+#
+
+pkgname="perl-test-pod"
+pkgver=1.26
+pkgrel=1
+pkgdesc="Translate Wiki formatted text to other formats"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~petdance/Test-Pod"
+license="unknown"
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/P/PE/PETDANCE/Test-Pod-$pkgver.tar.gz)
+md5sums=('2f259135656ac4549b65a4f14f07b7c6')
+
+build() {
+ cd $startdir/src/Test-Pod-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir/" install || return 1
+
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name 'perllocal.pod' -delete
+}
diff --git a/abs/core-testing/perl_modules/perl-time-modules/PKGBUILD b/abs/core-testing/perl_modules/perl-time-modules/PKGBUILD
new file mode 100644
index 0000000..6911ebc
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-time-modules/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Your Name <your_email@foobar.org>
+pkgname=perl-time-modules
+pkgver=2006.0814
+pkgrel=1
+pkgdesc="Parses Date strings"
+url="http://search.cpan.org/~muir/Time-modules-$pkgver/"
+depends=(perl)
+license="GPL"
+options=('!emptydirs')
+arch=('i686')
+source=(http://search.cpan.org/CPAN/authors/id/M/MU/MUIR/modules/Time-modules-$pkgver.tar.gz)
+md5sums=('790c6739f601b85654fac9ee516b18d8')
+
+build() {
+ cd $startdir/src/Time-modules-$pkgver
+ eval `perl -V:archname`
+ /usr/bin/perl Makefile.PL \
+ INSTALLARCHLIB=/usr/lib/perl5/current/${archname} \
+ INSTALLSITELIB=/usr/lib/perl5/site_perl/current \
+ INSTALLSITEARCH=/usr/lib/perl5/site_perl/current/${archname}
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install
+ /usr/bin/find $startdir/pkg -name '.packlist' -exec rm '{}' \;
+ /usr/bin/find $startdir/pkg -name '*.pod' -exec rm '{}' \;
+}
diff --git a/abs/core-testing/perl_modules/perl-unicode-map/PKGBUILD b/abs/core-testing/perl_modules/perl-unicode-map/PKGBUILD
new file mode 100644
index 0000000..1d03e86
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-unicode-map/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-unicode-map
+pkgver=0.112
+pkgrel=2
+pkgdesc="Unicode::Map"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~MSCHWARTZ/Unicode-Map"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/M/MS/MSCHWARTZ/Unicode-Map-$pkgver.tar.gz)
+md5sums=('edaa8fc5ddf0e5d805e274283dd0625d')
+
+build() {
+ cd $startdir/src/Unicode-Map-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/perl_modules/perl-x10/PKGBUILD b/abs/core-testing/perl_modules/perl-x10/PKGBUILD
new file mode 100644
index 0000000..51283d5
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-x10/PKGBUILD
@@ -0,0 +1,30 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Contributor: Ross melin <rdmelin@gmail.com>
+
+# Required by zoneminder
+
+pkgname=perl-x10
+pkgver=0.03
+pkgrel=2
+pkgdesc="X10"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~ROBF/X10"
+license=('GPL' 'PerlArtistic')
+depends=('perl-astro-suntime>=0.01' 'perl-device-serialport' 'perl-time-modules')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/R/RO/ROBF/X10-$pkgver.tar.gz)
+md5sums=('056b3d98fab545865148b948de6784c7')
+
+build() {
+ cd $startdir/src/X10-$pkgver
+ eval `perl -V:archname`
+ PERL_MM_USE_DEFAULT=1 /usr/bin/perl Makefile.PL \
+ INSTALLDIRS=vendor || return 1
+
+ /usr/bin/make || return 1
+ /usr/bin/make DESTDIR=$startdir/pkg install || return 1
+ /usr/bin/find $startdir/pkg -name '.packlist' -delete
+ /usr/bin/find $startdir/pkg -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: