summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/php
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-24 03:53:41 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-24 03:53:41 (GMT)
commit5c5c2effa0a2ba11497c60bf1c04e1fd09148836 (patch)
tree033c764cf268a06215d0f96d1b9dee8d8a07b76b /abs/core-testing/php
parent93d2a8342edb99eeb4450a898b99e9ff8ea7736c (diff)
downloadlinhes_pkgbuild-5c5c2effa0a2ba11497c60bf1c04e1fd09148836.zip
linhes_pkgbuild-5c5c2effa0a2ba11497c60bf1c04e1fd09148836.tar.gz
linhes_pkgbuild-5c5c2effa0a2ba11497c60bf1c04e1fd09148836.tar.bz2
change php/lighttpd configs to support mythweb.
Diffstat (limited to 'abs/core-testing/php')
-rw-r--r--abs/core-testing/php/PKGBUILD56
-rw-r--r--abs/core-testing/php/php.ini10
2 files changed, 32 insertions, 34 deletions
diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index 68ece33..c9c92ac 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,9 +1,6 @@
-# $Id: PKGBUILD 4664 2008-07-08 13:58:05Z allan $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-
pkgname=php
pkgver=5.2.6
-pkgrel=4
+pkgrel=6
_suhosinver=0.9.6.2
pkgdesc='A high-level scripting language'
arch=('i686' 'x86_64')
@@ -12,10 +9,15 @@ url='http://www.php.net'
backup=('etc/php/php.ini')
install=php.install
depends=('glibc' 'readline' 'ncurses' 'libxml2' 'pcre')
-makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' \
- 'libpng' 'libjpeg' 'sqlite3' 'unixodbc' 'net-snmp' \
- 'libmcrypt' 'tidyhtml' 'aspell' 'libtool' 'freetype2' 'libjpeg' \
+#makedepends=('apache' 'imap' 'postgresql-libs' 'mysql' 'libldap' \
+# 'libpng' 'libjpeg' 'sqlite3' 'unixodbc' 'net-snmp' \
+# 'libmcrypt' 'tidyhtml' 'aspell' 'libtool' 'freetype2' 'libjpeg' \
+# 'curl' 'libxslt' 'pam' 'openssl' 'bzip2' 'gdbm' 'db>=4.7')
+
+makedepends=('mysql' 'libpng' 'libjpeg' 'sqlite3' \
+ 'libmcrypt' 'libtool' 'freetype2' 'libjpeg' \
'curl' 'libxslt' 'pam' 'openssl' 'bzip2' 'gdbm' 'db>=4.7')
+
optdepends=('bzip2: bz2' \
'curl: curl' \
'gdbm: dba' \
@@ -40,11 +42,7 @@ options=('emptydirs')
source=("http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2" \
"http://download.suhosin.org/suhosin-patch-${pkgver}-${_suhosinver}.patch.gz" \
'php.ini' 'apache.conf' 'db-configure.patch')
-md5sums=('7380ffecebd95c6edb317ef861229ebd'
- 'f2ec986341a314c271259dbe4d940858'
- '0ee1dad48f7d67af3d2c78ca6eed68ba'
- '96ca078be6729b665be8a865535a97bf'
- '74e5ce5a02488ec91b1c59f539e42936')
+
build() {
phpconfig="--prefix=/usr \
@@ -78,9 +76,9 @@ build() {
--with-jpeg-dir=shared,/usr \
--with-png-dir=shared,/usr \
--with-gettext=shared \
- --with-imap=shared \
- --with-imap-ssl=shared \
- --with-ldap=shared \
+ --without-imap \
+ --without-imap-ssl \
+ --without-ldap \
--enable-mbstring=shared \
--with-mcrypt=shared \
--with-mysql=shared \
@@ -88,22 +86,22 @@ build() {
--with-mysql=shared \
--with-mysqli=shared \
--with-ncurses=shared \
- --with-unixODBC=shared,/usr \
+ --without-unixODBC \
--enable-pdo=shared \
--with-pdo-mysql=shared \
--with-pdo-sqlite=shared \
- --with-pdo-odbc=shared,unixODBC,/usr \
- --with-pdo-pgsql=shared \
+ --without-pdo-odbc \
+ --without-pdo-pgsql \
--with-sqlite=shared \
- --with-pgsql=shared \
+ --without-pgsql \
--enable-shmop=shared \
- --with-snmp=shared \
+ --without-snmp \
--enable-soap=shared \
--enable-sqlite-utf8=shared \
--enable-sysvmsg=shared \
--enable-sysvsem=shared \
--enable-sysvshm=shared \
- --with-tidy=shared \
+ --without-tidy \
--with-xsl=shared \
--enable-zip=shared \
--enable-posix=shared \
@@ -118,7 +116,7 @@ build() {
--enable-json=shared \
--with-iconv=shared \
--with-xmlrpc=shared \
- --with-pspell=shared \
+ --without-pspell \
--with-freetype-dir=shared,/usr \
--with-mime-magic=shared \
"
@@ -164,11 +162,11 @@ build() {
install -D -m755 sapi/cgi/php-cgi ${pkgdir}/usr/bin/php-cgi || return 1
# mod_php
- ./configure ${phpconfig} \
- --with-apxs2 \
- --disable-cli \
- ${phpextensions} || return 1
- make || return 1
- install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
- install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
+# ./configure ${phpconfig} \
+# --with-apxs2 \
+# --disable-cli \
+# ${phpextensions} || return 1
+# make || return 1
+# install -D -m644 libs/libphp5.so ${pkgdir}/usr/lib/httpd/modules/libphp5.so || return 1
+# install -D -m644 ${srcdir}/apache.conf ${pkgdir}/etc/httpd/conf/extra/php5_module.conf || return 1
}
diff --git a/abs/core-testing/php/php.ini b/abs/core-testing/php/php.ini
index 7f78d4a..7d5c1de 100644
--- a/abs/core-testing/php/php.ini
+++ b/abs/core-testing/php/php.ini
@@ -302,7 +302,7 @@ expose_php = Off
max_execution_time = 30 ; Maximum execution time of each script, in seconds
max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
;max_input_nesting_level = 64 ; Maximum input variable nesting level
-memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)
+memory_limit = 64M ; Maximum amount of memory a script may consume (32MB)
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
@@ -337,7 +337,7 @@ memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)
;
; - Show all errors, except for notices and coding standards warnings
;
-;error_reporting = E_ALL & ~E_NOTICE
+error_reporting = E_ALL & ~E_NOTICE
;
; - Show all errors, except for notices
;
@@ -368,7 +368,7 @@ error_reporting = E_ALL
;
; Default
;
-display_errors = Off
+display_errors = on
; Even when display_errors is on, errors that occur during PHP's startup
; sequence are not displayed. It's strongly recommended to keep
@@ -1270,7 +1270,7 @@ extension=gettext.so
;extension=ldap.so
;extension=mcrypt.so
;extension=mime_magic.so
-;extension=mysql.so
+extension=mysql.so
;extension=mysqli.so
;extension=ncurses.so
;extension=odbc.so
@@ -1281,7 +1281,7 @@ extension=gettext.so
;extension=pdo_pgsql.so
;extension=pdo_sqlite.so
;extension=pgsql.so
-;extension=posix.so
+extension=posix.so
;extension=pspell.so
extension=session.so
;extension=shmop.so