summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/ppl/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 05:53:51 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 05:53:51 (GMT)
commit9ed4a590299000e7328e1af912c117239a1cc75c (patch)
tree1e22028c4804644435518f1aeda60800bba89ac8 /abs/core-testing/ppl/PKGBUILD
parent5ad04ad706e074c7fde14f44fdaa377858b1b043 (diff)
downloadlinhes_pkgbuild-9ed4a590299000e7328e1af912c117239a1cc75c.zip
linhes_pkgbuild-9ed4a590299000e7328e1af912c117239a1cc75c.tar.gz
linhes_pkgbuild-9ed4a590299000e7328e1af912c117239a1cc75c.tar.bz2
ppl:Bumped/Updated for LinHES 7.
Diffstat (limited to 'abs/core-testing/ppl/PKGBUILD')
-rw-r--r--abs/core-testing/ppl/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core-testing/ppl/PKGBUILD b/abs/core-testing/ppl/PKGBUILD
new file mode 100644
index 0000000..e432e18
--- /dev/null
+++ b/abs/core-testing/ppl/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: PKGBUILD 72640 2010-03-19 03:03:03Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: ezzetabi <ezzetabi at gawab dot com>
+
+pkgname=ppl
+pkgver=0.10.2
+pkgrel=3
+pkgdesc="A modern library for convex polyhedra and other numerical abstractions."
+arch=('i686' 'x86_64')
+url="http://www.cs.unipr.it/ppl"
+license=('GPL3')
+depends=('gmp>=5.0')
+options=('!docs' '!libtool')
+source=(http://www.cs.unipr.it/ppl/Download/ftp/releases/$pkgver/ppl-$pkgver.tar.gz
+ ppl-0.10.2-gmp-5.0.patch)
+md5sums=('e7dd265afdeaea81f7e87a72b182d875'
+ '4da347693c76ccccba4fb5b60ca0f321')
+
+build() {
+ cd $srcdir/ppl-$pkgver
+ patch -Np1 -i $srcdir/ppl-0.10.2-gmp-5.0.patch
+ autoreconf -vf
+
+ ./configure --prefix=/usr --enable-interfaces="c,cxx" || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+}