summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/ppl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-09-10 01:50:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-09-10 01:50:14 (GMT)
commitaac56d7440da6f1d1f4e85c3baddd2d8ff735239 (patch)
tree3007c885601b515a3d5ea48186d23e8c54797f73 /abs/core-testing/ppl
parentf14927e1af177f820215e97b6ad716c8eca7ea94 (diff)
downloadlinhes_pkgbuild-aac56d7440da6f1d1f4e85c3baddd2d8ff735239.zip
linhes_pkgbuild-aac56d7440da6f1d1f4e85c3baddd2d8ff735239.tar.gz
linhes_pkgbuild-aac56d7440da6f1d1f4e85c3baddd2d8ff735239.tar.bz2
ppl: update to .11
Diffstat (limited to 'abs/core-testing/ppl')
-rw-r--r--abs/core-testing/ppl/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/abs/core-testing/ppl/PKGBUILD b/abs/core-testing/ppl/PKGBUILD
index e432e18..ee5979a 100644
--- a/abs/core-testing/ppl/PKGBUILD
+++ b/abs/core-testing/ppl/PKGBUILD
@@ -1,27 +1,27 @@
-# $Id: PKGBUILD 72640 2010-03-19 03:03:03Z allan $
+# $Id: PKGBUILD 87232 2010-08-11 12:07:18Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: ezzetabi <ezzetabi at gawab dot com>
pkgname=ppl
-pkgver=0.10.2
-pkgrel=3
+pkgver=0.11
+pkgrel=1
pkgdesc="A modern library for convex polyhedra and other numerical abstractions."
arch=('i686' 'x86_64')
url="http://www.cs.unipr.it/ppl"
license=('GPL3')
depends=('gmp>=5.0')
options=('!docs' '!libtool')
-source=(http://www.cs.unipr.it/ppl/Download/ftp/releases/$pkgver/ppl-$pkgver.tar.gz
- ppl-0.10.2-gmp-5.0.patch)
-md5sums=('e7dd265afdeaea81f7e87a72b182d875'
- '4da347693c76ccccba4fb5b60ca0f321')
+source=(http://www.cs.unipr.it/ppl/Download/ftp/releases/$pkgver/ppl-$pkgver.tar.gz)
+md5sums=('ba527ec0ffc830ce16fad8a4195a337e')
build() {
cd $srcdir/ppl-$pkgver
- patch -Np1 -i $srcdir/ppl-0.10.2-gmp-5.0.patch
- autoreconf -vf
+ ./configure --prefix=/usr --enable-interfaces="c,cxx"
+ make
+ make check
+}
- ./configure --prefix=/usr --enable-interfaces="c,cxx" || return 1
- make || return 1
- make DESTDIR=$pkgdir install || return 1
+package() {
+ cd $srcdir/ppl-$pkgver
+ make DESTDIR=$pkgdir install
}