summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/python/python-2.6-internal-expat.patch
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:41:04 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-11 18:41:04 (GMT)
commitbcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7 (patch)
tree1db739b5689e79de25ff05521ff1ef620478df50 /abs/core-testing/python/python-2.6-internal-expat.patch
parent22cb9c31cde8a125c3b7d159d8b50941cb5c7714 (diff)
downloadlinhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.zip
linhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.tar.gz
linhes_pkgbuild-bcf5ec3fa5da5bbac9a1eaba782bbcea0278d9b7.tar.bz2
Updated various packages.
Diffstat (limited to 'abs/core-testing/python/python-2.6-internal-expat.patch')
-rw-r--r--abs/core-testing/python/python-2.6-internal-expat.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/core-testing/python/python-2.6-internal-expat.patch b/abs/core-testing/python/python-2.6-internal-expat.patch
new file mode 100644
index 0000000..86252ab
--- /dev/null
+++ b/abs/core-testing/python/python-2.6-internal-expat.patch
@@ -0,0 +1,33 @@
+--- setup.py 2008-04-22 12:12:24.613554757 +0300
++++ setup.py 2008-04-22 12:13:09.276544063 +0300
+@@ -1035,18 +1035,15 @@
+ #
+ # More information on Expat can be found at www.libexpat.org.
+ #
+- expatinc = os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')
+- define_macros = [
+- ('HAVE_EXPAT_CONFIG_H', '1'),
+- ]
++ # Use system expat
++ expatinc = '/usr/include'
++ define_macros = []
+
+ exts.append(Extension('pyexpat',
+ define_macros = define_macros,
+ include_dirs = [expatinc],
++ libraries = ['expat'],
+ sources = ['pyexpat.c',
+- 'expat/xmlparse.c',
+- 'expat/xmlrole.c',
+- 'expat/xmltok.c',
+ ],
+ ))
+
+@@ -1058,6 +1055,7 @@
+ exts.append(Extension('_elementtree',
+ define_macros = define_macros,
+ include_dirs = [expatinc],
++ libraries = ['expat'],
+ sources = ['_elementtree.c'],
+ ))
+