summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit-scripts/runitscripts/services/evrouter
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:37:12 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-11 01:37:12 (GMT)
commit54e39512d743caf5afe2f587536135c450ea4fcf (patch)
tree22e7ba4ba242782064d36d7a3828b01800436d38 /abs/core-testing/runit-scripts/runitscripts/services/evrouter
parent8417e5e3b118ed9e12563a3d4fceeb38b9e73d4f (diff)
parent42129857874c470c65d3b1dcb4bf42945a98dcfa (diff)
downloadlinhes_pkgbuild-54e39512d743caf5afe2f587536135c450ea4fcf.zip
linhes_pkgbuild-54e39512d743caf5afe2f587536135c450ea4fcf.tar.gz
linhes_pkgbuild-54e39512d743caf5afe2f587536135c450ea4fcf.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Conflicts: abs/core-testing/LinHES-config/LinHES-release
Diffstat (limited to 'abs/core-testing/runit-scripts/runitscripts/services/evrouter')
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/evrouter/finish10
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/evrouter/run12
2 files changed, 18 insertions, 4 deletions
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/evrouter/finish b/abs/core-testing/runit-scripts/runitscripts/services/evrouter/finish
index 0dd33de..5ebda4c 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/evrouter/finish
+++ b/abs/core-testing/runit-scripts/runitscripts/services/evrouter/finish
@@ -1,4 +1,10 @@
#!/bin/bash
. /etc/profile
-DISPLAY=localhost:50 evrouter -q
-rm -rf /tmp/.evrouter*
+which evrouter >/dev/null 2>/dev/null
+if [ $? = 0 ]
+then
+ DISPLAY=localhost:50 evrouter -q
+ rm -rf /tmp/.evrouter*
+else
+ sv down evrouter
+fi \ No newline at end of file
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/evrouter/run b/abs/core-testing/runit-scripts/runitscripts/services/evrouter/run
index 1d7389a..5697f6f 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/evrouter/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/evrouter/run
@@ -1,5 +1,13 @@
#!/bin/bash
. /etc/profile
-sv start Xvfb
-su mythtv -c "DISPLAY=localhost:50 evrouter -c /etc/evrouter.cfg -f /dev/input/event*"
+which evrouter >/dev/null 2>/dev/null
+if [ $? = 0 ]
+then
+ ps -ef |grep -v grep|grep -q "Xvfb :50"
+ if [ ! $? = 0 ]
+ then
+ sv start Xvfb
+ fi
+ su mythtv -c "DISPLAY=localhost:50 evrouter -c /etc/evrouter.cfg -f /dev/input/event*"
+fi