summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-12-07 00:39:49 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-12-07 00:39:49 (GMT)
commit2ce20c77e0e643b5d60ef0dff4d689bb5a05f656 (patch)
treed74629d6ec777b9205bd19ac100bcf3df3255dec /abs/core-testing/runit-scripts
parent3211a5b7d8ddb4c7871f844036c366108ee57ef3 (diff)
downloadlinhes_pkgbuild-2ce20c77e0e643b5d60ef0dff4d689bb5a05f656.zip
linhes_pkgbuild-2ce20c77e0e643b5d60ef0dff4d689bb5a05f656.tar.gz
linhes_pkgbuild-2ce20c77e0e643b5d60ef0dff4d689bb5a05f656.tar.bz2
Add support for Autodetection of Hauppauge pvr-250 receivers. This should work
but I don't have a pvr-250 receiver anymore so can't fully test it. If PVR-250 is found then the old Hauppauge remote is assumed to be in use. Detection first checks for USB receivers, if no receiver is found it then checks for Hauppauge receivers. First found remote wins, so if a USB receiver is found the Hauppauge detection is never run. Oddly enough I never wanted to use a Hauppauage receiver again, but somehow I spent most of the adding support for it.
Diffstat (limited to 'abs/core-testing/runit-scripts')
-rwxr-xr-xabs/core-testing/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/12
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/lircd/run4
3 files changed, 5 insertions, 3 deletions
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index 6df1bae..cc00956 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=18
+pkgrel=21
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/1 b/abs/core-testing/runit-scripts/runitscripts/1
index 748930f..b9ff184 100755
--- a/abs/core-testing/runit-scripts/runitscripts/1
+++ b/abs/core-testing/runit-scripts/runitscripts/1
@@ -2,7 +2,7 @@
/etc/rc.sysinit
hostname `cat /etc/hostname`
/sbin/sysctl -p 2>/dev/null >/dev/null
-#/usr/bin/load-modules-mythvantage.sh
+/usr/LH/bin/load-modules-mythvantage.sh
rm /etc/dhcpc/dhcpcd*.pid 2>/dev/null
rm -f /etc/sv/frontend/.runtime/* 2>/dev/null
rm -f /etc/runit/reboot 2>/dev/null
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
index 9908256..ceda8db 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
@@ -33,7 +33,9 @@ case $ReceiverType in
Usb-imon)
DEVICE=/dev/lirc_imon
;;
-
+ Hauppauge)
+ DEVICE=/dev/lirc3
+ ;;
*)
DEVICE=`ls /dev/lirc[0-9] 2>/dev/null |sort |sed '/./,$!d'|head -n 1 `