summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-04-21 20:04:56 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-04-21 20:04:56 (GMT)
commit97d9421d3499ab7b9fcc8459cc8d5cfb92dc60a5 (patch)
tree7b879c5a60bbf1e8c1a43daaeb5c16e425d77282 /abs/core-testing/runit-scripts
parente98bca336dab3ae48854c5d3e4370ed979b7322e (diff)
downloadlinhes_pkgbuild-97d9421d3499ab7b9fcc8459cc8d5cfb92dc60a5.zip
linhes_pkgbuild-97d9421d3499ab7b9fcc8459cc8d5cfb92dc60a5.tar.gz
linhes_pkgbuild-97d9421d3499ab7b9fcc8459cc8d5cfb92dc60a5.tar.bz2
runit-scripts: add igdaemon and tatir.
Diffstat (limited to 'abs/core-testing/runit-scripts')
-rwxr-xr-xabs/core-testing/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/igdaemon/run9
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/lircd/run49
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/tatir/run9
4 files changed, 45 insertions, 24 deletions
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index d94fc91..6596371 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=77
+pkgrel=83
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/igdaemon/run b/abs/core-testing/runit-scripts/runitscripts/services/igdaemon/run
new file mode 100755
index 0000000..ea4f33b
--- /dev/null
+++ b/abs/core-testing/runit-scripts/runitscripts/services/igdaemon/run
@@ -0,0 +1,9 @@
+#!/bin/sh
+exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting IguanaWorks IR daemon"
+
+
+exec /usr/bin/igdaemon --no-ids -n -l /var/log/igdaemon.log
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
index 914f5cf..59206ae 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
@@ -59,36 +59,39 @@ else
sleep .5
/sbin/modprobe lirc_serial $FLAGS
sleep .5
- fi
- if [ x$HostBlasterType = xSerial ]
+ elif [ x$HostBlasterType = xSerial ]
then
- case $HostSerialPort_blasterlirc in
- ttyS0)
- FLAGS="io=0x3f8 irq=4"
- ;;
- ttyS1)
- FLAGS="io=0x2f8 irq=3"
- ;;
- ttyS2)
- FLAGS="io=0x3e8 irq=4"
- ;;
- ttyS3)
- FLAGS="io=0x2f8 irq=3"
- ;;
- esac
- /usr/bin/setserial /dev/$ReceiverSerialport uart none
- sleep .5
- /sbin/modprobe lirc_serial $FLAGS
- sleep .5
+ case $HostSerialPort_blasterlirc in
+ ttyS0)
+ FLAGS="io=0x3f8 irq=4"
+ ;;
+ ttyS1)
+ FLAGS="io=0x2f8 irq=3"
+ ;;
+ ttyS2)
+ FLAGS="io=0x3e8 irq=4"
+ ;;
+ ttyS3)
+ FLAGS="io=0x2f8 irq=3"
+ ;;
+ esac
+ /usr/bin/setserial /dev/$ReceiverSerialport uart none
+ sleep .5
+ /sbin/modprobe lirc_serial $FLAGS
+ sleep .5
fi
dvico_detect
- if [ x$HostBlasterType = xCommandIR -o x$HostBlasterType = xCommandIR ]
+ if [ x$HostBlasterType = xCommandIR -o x$ReceiverType = xCommandIR ]
then
- rmmod commandir 2>/dev/null
CMD="/usr/sbin/lircd -n --driver=commandir"
printhl " Using commandir"
-
+ $CMD >>$LOG 2>>$LOG
+ elif [ x$HostBlasterType = xiguanaIR-usb -o x$ReceiverType = xiguanaIR-usb ]
+ then
+ sv start igdaemon
+ CMD="/usr/sbin/lircd -n --driver=iguanaIR"
+ printhl " Using iguanaIR usb"
$CMD >>$LOG 2>>$LOG
else
LASTCMD=""
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/tatir/run b/abs/core-testing/runit-scripts/runitscripts/services/tatir/run
new file mode 100755
index 0000000..d6fc863
--- /dev/null
+++ b/abs/core-testing/runit-scripts/runitscripts/services/tatir/run
@@ -0,0 +1,9 @@
+#!/bin/sh
+exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting tatir"
+
+
+exec /usr/bin/PyroUsb.py > /dev/null