summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-02-17 04:54:11 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-02-17 04:54:11 (GMT)
commit52e7c7e6d99e3d515936d9c51f9fbe65179e5153 (patch)
tree54f63137199aa3b3db7b22b84e820fe29842fc82 /abs/core-testing/runit/PKGBUILD
parent7c4c17e34fbf3da4024656a99643b4062719513b (diff)
downloadlinhes_pkgbuild-52e7c7e6d99e3d515936d9c51f9fbe65179e5153.zip
linhes_pkgbuild-52e7c7e6d99e3d515936d9c51f9fbe65179e5153.tar.gz
linhes_pkgbuild-52e7c7e6d99e3d515936d9c51f9fbe65179e5153.tar.bz2
Quick replacment shutdown command for runit.
it accepts the -t -r -h commands like init shutdown and errors out for all others.
Diffstat (limited to 'abs/core-testing/runit/PKGBUILD')
-rwxr-xr-xabs/core-testing/runit/PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/abs/core-testing/runit/PKGBUILD b/abs/core-testing/runit/PKGBUILD
index c0863bb..1303167 100755
--- a/abs/core-testing/runit/PKGBUILD
+++ b/abs/core-testing/runit/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit
pkgver=1.8.0
-pkgrel=57
+pkgrel=61
pkgdesc="A replacement for sysvinit, and other init schemes, with service supervision"
url="http://smarden.org/runit/"
license="BSD"
@@ -10,7 +10,7 @@ conflicts=()
replaces=()
backup=()
install=runit.install
-source=(http://smarden.org/runit/$pkgname-$pkgver.tar.gz add_service.sh remove_service.sh halt.script reboot.script poweroff.script)
+source=(http://smarden.org/runit/$pkgname-$pkgver.tar.gz add_service.sh remove_service.sh halt.script reboot.script poweroff.script shutdown.script)
arch=('i686')
build() {
@@ -35,6 +35,7 @@ build() {
install -m0755 $startdir/src/reboot.script $startdir/pkg/sbin
install -m0755 $startdir/src/halt.script $startdir/pkg/sbin
install -m0755 $startdir/src/poweroff.script $startdir/pkg/sbin
+ install -m0755 $startdir/src/shutdown.script $startdir/pkg/sbin
for i in `cat ../package/commands`; do
install -m0755 $i $startdir/pkg/sbin/