summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/smbclient
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-28 21:10:31 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-28 21:10:31 (GMT)
commite65efe930ec0f86eb207fabf8a5502d23af566a2 (patch)
treee86be0c30dc17e08ac25358dfafe47055e377291 /abs/core-testing/smbclient
parent9f392cc1b6e39b4cde757e18aa8259f2724e41fe (diff)
downloadlinhes_pkgbuild-e65efe930ec0f86eb207fabf8a5502d23af566a2.zip
linhes_pkgbuild-e65efe930ec0f86eb207fabf8a5502d23af566a2.tar.gz
linhes_pkgbuild-e65efe930ec0f86eb207fabf8a5502d23af566a2.tar.bz2
add samba & update smb-client
Diffstat (limited to 'abs/core-testing/smbclient')
-rw-r--r--abs/core-testing/smbclient/PKGBUILD52
-rw-r--r--abs/core-testing/smbclient/heimdal.patch33
2 files changed, 25 insertions, 60 deletions
diff --git a/abs/core-testing/smbclient/PKGBUILD b/abs/core-testing/smbclient/PKGBUILD
index b7eb349..5e423ebe 100644
--- a/abs/core-testing/smbclient/PKGBUILD
+++ b/abs/core-testing/smbclient/PKGBUILD
@@ -1,53 +1,50 @@
-# $Id: PKGBUILD 3859 2008-07-01 17:10:34Z andyrtr $
+# $Id: PKGBUILD 14139 2008-10-04 09:13:09Z tpowa $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgname=smbclient
-pkgver=3.0.31
+pkgver=3.2.4
# We use the 'A' to fake out pacman's version comparators. Samba chooses
# to append 'a','b',etc to their subsequent releases, which pamcan
# misconstrues as alpha, beta, etc. Bad samba!
-_realver=3.0.31
-pkgrel=2
+_realver=3.2.4
+pkgrel=3
pkgdesc="Tools to access a server's filespace and printers via SMB"
arch=(i686 x86_64)
url="http://www.samba.org"
-license=('GPL')
-options=(!makeflags)
-depends=('popt' 'libldap' 'libcap' 'heimdal>=1.2-1' 'db>=4.7')
+license=('GPL3')
+depends=('popt' 'libldap' 'libcap' 'heimdal>=1.2-1' 'db>=4.7' 'tdb=3.2.4')
source=(http://us1.samba.org/samba/ftp/samba-${_realver}.tar.gz)
-md5sums=('165abaf4522c70031d9a76fbb638ca06')
+options=(!makeflags)
build() {
cd ${startdir}/src/samba-${_realver}/source
- ./configure --prefix=/usr --with-smbmount --with-fhs --with-pam \
+ ./configure --prefix=/usr --with-cifsmount --with-fhs --with-pam \
--with-datadir=/usr/share --with-configdir=/etc/samba \
--with-lockdir=/var/run/samba --with-ads --with-acl-support \
- --localstatedir=/var
+ --localstatedir=/var --disable-dnssd --libdir=/usr/lib/samba
+
make proto bin/smbclient libsmbclient \
bin/rpcclient bin/smbspool bin/smbtree \
- bin/smbcacls bin/smbcquotas bin/smbmount bin/smbmnt bin/smbget \
- bin/smbumount bin/net bin/nmblookup || return 1
- mkdir -p ${startdir}/pkg/usr/bin ${startdir}/pkg/sbin
- install -m755 bin/* ${startdir}/pkg/usr/bin/
+ bin/smbcacls bin/smbcquotas bin/smbget \
+ bin/net bin/nmblookup bin/mount.cifs bin/umount.cifs || return 1
+ mkdir -p ${startdir}/pkg/usr/bin ${startdir}/pkg/sbin ${startdir}/pkg/usr/lib/samba
+ install -m755 bin/{smbclient,rpcclient,smbspool,smbtree,smbcacls,smbcquotas,smbget,net,nmblookup} ${startdir}/pkg/usr/bin/
+ install -m755 bin/{mount.cifs,umount.cifs} ${startdir}/pkg/sbin/
+ mv bin/*.so* ${startdir}/pkg/usr/lib/samba
install -m755 script/smbtar ${startdir}/pkg/usr/bin/
- ln -sf /usr/bin/smbmount ${startdir}/pkg/sbin/mount.smbfs
- ln -sf /usr/bin/smbumount ${startdir}/pkg/sbin/umount.smbfs
mkdir -p ${startdir}/pkg/usr/lib/cups/backend
ln -sf /usr/bin/smbspool ${startdir}/pkg/usr/lib/cups/backend/smb
-
- mkdir -p ${startdir}/pkg/usr/lib/samba
- mv ${startdir}/pkg/usr/bin/libsmbclient.* ${startdir}/pkg/usr/lib/samba/
- ln -sf samba/libsmbclient.so ${startdir}/pkg/usr/lib/libsmbclient.so
- ln -sf samba/libsmbclient.so ${startdir}/pkg/usr/lib/libsmbclient.so.0
+ for i in ${startdir}/pkg/usr/lib/samba/*; do
+ ln -sf samba/$(basename $i) ${startdir}/pkg/usr/lib/$(basename $i)
+ done
+ rm -rf $startdir/pkg/usr/lib/libtdb*
mkdir -p ${startdir}/pkg/usr/include
install -m644 include/libsmbclient.h ${startdir}/pkg/usr/include/
-
- gcc -Wall -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -o ${startdir}/pkg/sbin/mount.cifs client/mount.cifs.c
- gcc -Wall -D_GNU_SOURCE -D_LARGEFILE64_SOURCE -o ${startdir}/pkg/sbin/umount.cifs client/umount.cifs.c
-
+ install -m644 lib/talloc/talloc.h ${startdir}/pkg/usr/include/
+ install -m644 lib/netapi/netapi.h ${startdir}/pkg/usr/include/
mkdir -p ${startdir}/pkg/usr/share/man/man{1,7,8}
- for man in smbmnt smbmount smbspool \
- smbumount umount.cifs mount.cifs net; do
+ for man in smbspool \
+ umount.cifs mount.cifs net; do
install -m644 ../docs/manpages/${man}.8 ${startdir}/pkg/usr/share/man/man8/
done
for man in rpcclient smbcacls smbclient smbcquotas smbget \
@@ -56,3 +53,4 @@ build() {
done
install -m644 ../docs/manpages/libsmbclient.7 ${startdir}/pkg/usr/share/man/man7/
}
+md5sums=('7870a6bb3a025c6081cd56688acd494a')
diff --git a/abs/core-testing/smbclient/heimdal.patch b/abs/core-testing/smbclient/heimdal.patch
deleted file mode 100644
index d116d3e..0000000
--- a/abs/core-testing/smbclient/heimdal.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Submitted By: Randy McMurchy <randy_at_linuxfromscratch_dot_org>
-Date: 2005-09-21
-Initial Package Version: 3.0.20
-Upstream Status: Not submitted (it is not an upstream Samba issue)
-Origin: Randy McMurchy
-Description: Fixes an issue if you have Heimdal installed as
- Heimdal uses reserved C++ words and the Samba headers
- now look for these conflicts. This patch comments out
- the check for C++ reserved words. Heimdal is aware of
- the issue
-
-$LastChangedBy: randy $
-$Date: 2005/11/17 12:32:28 $
-
-
---- samba-3.0.20-orig/source/include/includes.h 2005-07-28 13:19:49.000000000 +0000
-+++ samba-3.0.20/source/include/includes.h 2005-09-04 13:45:01.000000000 +0000
-@@ -25,6 +25,7 @@
- #include "config.h"
- #endif
-
-+/*
- #ifndef __cplusplus
- #define class #error DONT_USE_CPLUSPLUS_RESERVED_NAMES
- #define private #error DONT_USE_CPLUSPLUS_RESERVED_NAMES
-@@ -36,6 +37,7 @@
- #define delete #error DONT_USE_CPLUSPLUS_RESERVED_NAMES
- #define friend #error DONT_USE_CPLUSPLUS_RESERVED_NAMES
- #endif
-+*/
-
- #include "local.h"
-