summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/squashfs-tools/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 05:57:11 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2010-09-05 05:57:11 (GMT)
commitb6a2f8e91911b396508ceec7da17414b809c1561 (patch)
treefd91927a1d1d6104a1f1baf5fbc80a9854b0193f /abs/core-testing/squashfs-tools/PKGBUILD
parentf86b8321c37771b0732eca21876cc8c01ab696eb (diff)
downloadlinhes_pkgbuild-b6a2f8e91911b396508ceec7da17414b809c1561.zip
linhes_pkgbuild-b6a2f8e91911b396508ceec7da17414b809c1561.tar.gz
linhes_pkgbuild-b6a2f8e91911b396508ceec7da17414b809c1561.tar.bz2
squashfs:Bumped/Updated for LinHES 7.
Diffstat (limited to 'abs/core-testing/squashfs-tools/PKGBUILD')
-rw-r--r--abs/core-testing/squashfs-tools/PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/abs/core-testing/squashfs-tools/PKGBUILD b/abs/core-testing/squashfs-tools/PKGBUILD
index dd17001..fb99564 100644
--- a/abs/core-testing/squashfs-tools/PKGBUILD
+++ b/abs/core-testing/squashfs-tools/PKGBUILD
@@ -1,24 +1,25 @@
-# $Id: PKGBUILD 3162 2008-06-20 23:18:11Z simo $
+# $Id: PKGBUILD 70339 2010-02-26 03:50:39Z dgriffiths $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Original TU: Jeff Mickey <j@codemac.net>
# Contributor: ciccio.a
pkgname=squashfs-tools
-pkgver=3.3
-_realver=3.3
-pkgrel=1
+pkgver=4.0
+pkgrel=3
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="http://squashfs.sourceforge.net"
-license="GPL"
+license=("GPL")
arch=('i686' 'x86_64')
depends=('zlib' 'glibc')
-source=(http://easynews.dl.sourceforge.net/sourceforge/squashfs/squashfs$_realver.tar.gz)
-md5sums=('62d3ff7c067a5aa82f57711b3a4ab86a')
+source=(http://downloads.sourceforge.net/sourceforge/squashfs/squashfs${pkgver}.tar.gz mksquashfs-fix-race.patch)
build()
{
- cd $startdir/src/squashfs$_realver/$pkgname
+ cd ${srcdir}/squashfs${pkgver}/${pkgname}
+ patch < ${srcdir}/mksquashfs-fix-race.patch || return 1
make || return 1
- mkdir -p $startdir/pkg/sbin
- cp -a mksquashfs unsquashfs $startdir/pkg/sbin
+ install -Dm755 mksquashfs ${pkgdir}/sbin/mksquashfs || return 1
+ install -m755 unsquashfs ${pkgdir}/sbin/unsquashfs || return 1
}
+md5sums=('a3c23391da4ebab0ac4a75021ddabf96'
+ '116b8a285ff8d61d59c48eb80c0ff564')