summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/talloc
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-02-04 00:27:56 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-02-04 00:27:56 (GMT)
commit269814461419fa29c84e7493b0b1c91b03e0d9eb (patch)
treec470659fbf18e93b7f30611757123a63009f5bf4 /abs/core-testing/talloc
parent1a0b759963b626c3431d3eb967789cad741a73f3 (diff)
downloadlinhes_pkgbuild-269814461419fa29c84e7493b0b1c91b03e0d9eb.zip
linhes_pkgbuild-269814461419fa29c84e7493b0b1c91b03e0d9eb.tar.gz
linhes_pkgbuild-269814461419fa29c84e7493b0b1c91b03e0d9eb.tar.bz2
samba: update to 3.4.5.
This pkgbuild also builds smbclient added: talloc tdb
Diffstat (limited to 'abs/core-testing/talloc')
-rw-r--r--abs/core-testing/talloc/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core-testing/talloc/PKGBUILD b/abs/core-testing/talloc/PKGBUILD
new file mode 100644
index 0000000..903de2d
--- /dev/null
+++ b/abs/core-testing/talloc/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 63108 2010-01-14 18:54:03Z tpowa $
+# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=talloc
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="talloc is a hierarchical pool based memory allocator with destructors"
+arch=(i686 x86_64)
+license=('GPL3')
+url="http://tdb.samba.org/"
+source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+depends=('glibc')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ --enable-talloc-compat1 \
+ --enable-largefile
+ make || return 1
+ make DESTDIR=$pkgdir/ install
+ # fix permission
+ chmod 644 $pkgdir/usr/lib/libtalloc.a
+}
+md5sums=('c6e736540145ca58cb3dcb42f91cf57b')