summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tiacx/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-01-07 09:44:40 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-01-07 09:44:40 (GMT)
commit22cb9c31cde8a125c3b7d159d8b50941cb5c7714 (patch)
treeffdf1f5463d1c6fcc968ef15a82837210fba0a39 /abs/core-testing/tiacx/PKGBUILD
parentf018045129450cc43d0e86eedcdd7b43d53ff691 (diff)
downloadlinhes_pkgbuild-22cb9c31cde8a125c3b7d159d8b50941cb5c7714.zip
linhes_pkgbuild-22cb9c31cde8a125c3b7d159d8b50941cb5c7714.tar.gz
linhes_pkgbuild-22cb9c31cde8a125c3b7d159d8b50941cb5c7714.tar.bz2
Updated kernel to 2.6.27. Updated latest PKGBUILD for various packages and recompiled.
Diffstat (limited to 'abs/core-testing/tiacx/PKGBUILD')
-rw-r--r--abs/core-testing/tiacx/PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/abs/core-testing/tiacx/PKGBUILD b/abs/core-testing/tiacx/PKGBUILD
index d1bffc7..2e2e831 100644
--- a/abs/core-testing/tiacx/PKGBUILD
+++ b/abs/core-testing/tiacx/PKGBUILD
@@ -1,22 +1,25 @@
-# $Id: PKGBUILD 5944 2008-07-21 20:26:41Z thomas $
+# $Id: PKGBUILD 14786 2008-10-10 15:36:27Z thomas $
# Maintainer: James Rayner <iphitus@gmail.com>
pkgname=tiacx
pkgver=20080210
-pkgrel=6
+pkgrel=7
pkgdesc="OpenSource module for Texas Instruments ACX100/ACX111 wireless chips. For stock arch 2.6 kernel"
arch=(i686 x86_64)
url="http://acx100.sourceforge.net/"
license=('MPL')
-depends=('wireless_tools' 'kernel26>=2.6.26-1' 'kernel26<2.6.27' 'tiacx-firmware')
+depends=('wireless_tools' 'kernel26>=2.6.27' 'kernel26<2.6.28' 'tiacx-firmware')
install=acx.install
-source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2)
-md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12')
+source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2
+ kernel-2.6.27.patch)
+md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12'
+ '9895f72f8d0c84956b0f6c3b16df0fe8')
-_kernver=2.6.26-ARCH
+_kernver=2.6.27-ARCH
build() {
cd $startdir/src/acx-$pkgver
+ patch -Np1 -i ../kernel-2.6.27.patch || return 1
make -C /lib/modules/${_kernver}/build M=`pwd` || return 1
install -D acx.ko $startdir/pkg/lib/modules/${_kernver}/kernel/drivers/net/wireless/tiacx/acx.ko
sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/*.install