summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tweaker/PKGBUILD
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-01-17 17:53:44 (GMT)
committerBob Igo <bob@stormlogic.com>2009-01-17 17:53:44 (GMT)
commit18b8c17f24b9cd6d9600b212cbd615deb69fe500 (patch)
treece8b68a2277d4d81706c9f71832540a91361919e /abs/core-testing/tweaker/PKGBUILD
parente2f581d7a980085e0078e01f1a38886ab88127ec (diff)
downloadlinhes_pkgbuild-18b8c17f24b9cd6d9600b212cbd615deb69fe500.zip
linhes_pkgbuild-18b8c17f24b9cd6d9600b212cbd615deb69fe500.tar.gz
linhes_pkgbuild-18b8c17f24b9cd6d9600b212cbd615deb69fe500.tar.bz2
Expanded Tweaker tar file into individual files, and adjusted installation process to reflect this. Further integration will be required before this is ready for R6.
Diffstat (limited to 'abs/core-testing/tweaker/PKGBUILD')
-rw-r--r--abs/core-testing/tweaker/PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index a11643b..bb5a401 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -6,7 +6,7 @@ arch=('i686' 'x86_64')
depends=('bash' 'perl' 'perl-dbi' 'perl-exception-class' 'perl-log-log4perl' 'perl-log-dispatch' 'perl-getopt-lucid' 'perl-list-member' 'perl-class-data-inheritable' 'perl-devel-stacktrace' 'perl-xml-twig')
-source=(${pkgname}.tar.bz2 tweaker.sh log4perl.conf)
+source=(tweaker.sh log4perl.conf bin/tweaker.pl bin/twk_audio.pl bin/twk_audio_RP.pl bin/twk_cpu.pl bin/twk_dragon.pl bin/twk_EXAMPLE.pl bin/twk_fingerprint_hardware.sh bin/twk_general.pl bin/twk_graphics.pl bin/twk_keymap.sh bin/twk_linux.pl bin/twk_localization.pl bin/twk_misc.pl bin/twk_RAM.pl bin/twk_scrub_sql.pl bin/twk_tuners.pl bin/twk_upgrade.pl bin/twk_what_has_changed.sh tcf/EXAMPLE.tcf tcf/focus.tcf tcf/os.tcf tcf/tcf.dtd tcf/tweaker-core.tcf tcf/userland.tcf fs/etc/asound.conf fs/var/lib/alsa/ALC888.asound.state fs/var/lib/alsa/AV710.asound.state lib/Tweaker/Definitions.pm lib/Tweaker/Script.pm)
license=('GPL2')
#groups=('pvr')
@@ -14,21 +14,24 @@ license=('GPL2')
#install=tweaker.install
build() {
- TWEAKER_ROOT=$startdir/pkg/usr/LH/tweaker
- cd $startdir/src/ || return 1
- mkdir -p $TWEAKER_ROOT/bin
+ TWEAKER_ROOT=/usr/LH/tweaker
+ mkdir -p $TWEAKER_ROOT
+ cd $TWEAKER_ROOT
+ # executables
+ install -m0777 -d bin $startdir/bin
+ # parallel root directory structure used for seeding configuration files
+ install -m0777 -d fs $startdir/fs
+ # Tweaker configuration files
+ install -m0555 -d tcf $startdir/tcf
+ # Tweaker-centric log4perl configuration
+ cd /etc
+ install -m0755 log4perl.conf $startdir/log4perl.conf
+
+ # Ensure shell variables are configured at start; ensure $TWEAKER_ROOT/bin is in $PATH
mkdir -p $startdir/pkg/etc/profile.d
install -m0755 tweaker.sh $startdir/pkg/etc/profile.d/tweaker.sh
- install -m0755 log4perl.conf $TWEAKER_ROOT/log4perl.conf
-
- #copy binary files
- cd usr/local/bin
- install -m0755 * $TWEAKER_ROOT/bin/
- rm -f $TWEAKER_ROOT/bin/tweaker-installer.sh
-
-#copied lib from km 5.5 because it was missing from the tar file
- mkdir -p $TWEAKER_ROOT
- cd $startdir/src/usr/LH/tweaker
- cp -rp * $TWEAKER_ROOT
+ # Link our tweaker Perl modules for general use
+ /bin/ln -fs $TWEAKER_ROOT/lib/Tweaker /etc/perl/
+ /bin/cp $startdir/fs/etc/log4perl.conf /etc
}