summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tweaker/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2009-02-07 19:01:21 (GMT)
committerJames Meyer <James.meyer@operamail.com>2009-02-07 19:01:21 (GMT)
commit2ee6cf133acb178f6f0bd880712431e74d63e557 (patch)
tree97f8c830ca3033427ed135159695b1142c6c6824 /abs/core-testing/tweaker/PKGBUILD
parent096b016164d6231d9c323bbcfb0ac68789740ea9 (diff)
downloadlinhes_pkgbuild-2ee6cf133acb178f6f0bd880712431e74d63e557.zip
linhes_pkgbuild-2ee6cf133acb178f6f0bd880712431e74d63e557.tar.gz
linhes_pkgbuild-2ee6cf133acb178f6f0bd880712431e74d63e557.tar.bz2
Changes to tweaker PKGBUILD so that the pkg is built.
Have not tested tweaker beyond running tweaker.pl
Diffstat (limited to 'abs/core-testing/tweaker/PKGBUILD')
-rw-r--r--abs/core-testing/tweaker/PKGBUILD31
1 files changed, 20 insertions, 11 deletions
diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index c7cb9c3..d777e72 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -1,36 +1,45 @@
pkgname=tweaker
pkgver=1
-pkgrel=11
+pkgrel=16
pkgdesc=""
arch=('i686' 'x86_64')
depends=('bash' 'perl' 'perl-dbi' 'perl-exception-class' 'perl-log-log4perl' 'perl-log-dispatch' 'perl-getopt-lucid' 'perl-list-member' 'perl-class-data-inheritable' 'perl-devel-stacktrace' 'perl-xml-twig')
-source=(tweaker.sh log4perl.conf bin/tweaker.pl bin/twk_audio.pl bin/twk_audio_RP.pl bin/twk_cpu.pl bin/twk_dragon.pl bin/twk_EXAMPLE.pl bin/twk_fingerprint_hardware.sh bin/twk_general.pl bin/twk_graphics.pl bin/twk_keymap.sh bin/twk_linux.pl bin/twk_localization.pl bin/twk_misc.pl bin/twk_RAM.pl bin/twk_scrub_sql.pl bin/twk_tuners.pl bin/twk_upgrade.pl bin/twk_what_has_changed.sh tcf/EXAMPLE.tcf tcf/focus.tcf tcf/os.tcf tcf/tcf.dtd tcf/tweaker-core.tcf tcf/userland.tcf fs/etc/asound.conf fs/var/lib/alsa/ALC888.asound.state fs/var/lib/alsa/AV710.asound.state lib/Tweaker/Definitions.pm lib/Tweaker/Script.pm)
+source=(tweaker.sh log4perl.conf)
license=('GPL2')
#groups=('pvr')
-#install=tweaker.install
+install=tweaker.install
build() {
- TWEAKER_ROOT=/usr/LH/tweaker
+ TWEAKER_ROOT=usr/LH/tweaker
mkdir -p $startdir/pkg/$TWEAKER_ROOT
-
+ mkdir -p $startdir/pkg/$TWEAKER_ROOT/{bin,fs,tcf}
+ mkdir -p $startdir/pkg/etc/profile.d
+ mkdir -p $startdir/pkg/usr/lib/perl5/vendor_perl/Tweaker/
+
+ cd $startdir
# executables
- install -m0777 -d bin $startdir/pkg/$TWEAKER_ROOT/bin
+ install -m0777 -D bin/* $startdir/pkg/$TWEAKER_ROOT/bin
+
+
# parallel root directory structure used for seeding configuration files
- install -m0777 -d fs $startdir/pkg/$TWEAKER_ROOT/fs
+# install -m0777 -D fs/ $startdir/pkg/$TWEAKER_ROOT/fs
+ cp -rp fs $startdir/pkg/$TWEAKER_ROOT/
+ chmod -R 0777 $startdir/pkg/$TWEAKER_ROOT/
+
# Tweaker configuration files
- install -m0555 -d tcf $startdir/pkg/$TWEAKER_ROOT/tcf
+ install -m0555 -D tcf/* $startdir/pkg/$TWEAKER_ROOT/tcf
# Tweaker-centric log4perl configuration
- install -m0755 log4perl.conf $startdir/pkg/etc/log4perl.conf
+ #install -m0755 log4perl.conf $startdir/pkg/etc/log4perl.conf
+ install -m0755 log4perl.conf $startdir/pkg/$TWEAKER_ROOT
# Ensure shell variables are configured at start; ensure $TWEAKER_ROOT/bin is in $PATH
- mkdir -p $startdir/pkg/etc/profile.d
install -m0755 tweaker.sh $startdir/pkg/etc/profile.d/tweaker.sh
# Copy our tweaker Perl modules for general use
- install -m0555 -d lib/Tweaker $startdir/pkg/usr/lib/perl5/vendor_perl/Tweaker
+ install -m0555 lib/Tweaker/* $startdir/pkg/usr/lib/perl5/vendor_perl/Tweaker/
}