summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tweaker/lib/Tweaker/Definitions.pm
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-17 23:10:05 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-17 23:10:05 (GMT)
commit676926ddca2543eb6a6bd34fe4350d1618e45b56 (patch)
tree97c428d568e852bb14284d00ceee8194e3271a80 /abs/core-testing/tweaker/lib/Tweaker/Definitions.pm
parentfa3e0f88f1a55d88f522d770e0e8386efe924825 (diff)
parent100e02faeb525e8f697b0c8c6bc4a3eb2179c8b3 (diff)
downloadlinhes_pkgbuild-676926ddca2543eb6a6bd34fe4350d1618e45b56.zip
linhes_pkgbuild-676926ddca2543eb6a6bd34fe4350d1618e45b56.tar.gz
linhes_pkgbuild-676926ddca2543eb6a6bd34fe4350d1618e45b56.tar.bz2
Merge branch 'HEAD' of ssh://jams@knoppmyth.net/mount/repository/LinHES-PKGBUILD.git
Diffstat (limited to 'abs/core-testing/tweaker/lib/Tweaker/Definitions.pm')
-rw-r--r--abs/core-testing/tweaker/lib/Tweaker/Definitions.pm66
1 files changed, 66 insertions, 0 deletions
diff --git a/abs/core-testing/tweaker/lib/Tweaker/Definitions.pm b/abs/core-testing/tweaker/lib/Tweaker/Definitions.pm
new file mode 100644
index 0000000..cbadf29
--- /dev/null
+++ b/abs/core-testing/tweaker/lib/Tweaker/Definitions.pm
@@ -0,0 +1,66 @@
+# Copyright 2007 Robert ("Bob") Igo of StormLogic, LLC and mythic.tv.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+package Tweaker::Definitions;
+use List::Member;
+use Log::Log4perl qw(:easy);
+
+# To install the above modules:
+# --
+# sudo cpan install List::Member
+
+# Recommendation Levels
+my $bottom = -200; # a reserved value, under which no recommendationlevel can go
+my $not_available = -100;
+my $unsupported = -99;
+my $inadvisable = -50;
+my $optional = 0;
+my $recommended = 100;
+
+# Interactivity Levels
+my $guided = "guided";
+my $minimal = "minimal";
+
+# Special variables
+my $null = "null"; # reserved as the script name for special Tweaks that define Tweaker behavior
+
+my %global_variable_hash = (
+ "bottom" => $bottom,
+ "not available" => $not_available,
+ "unsupported" => $unsupported,
+ "inadvisable" => $inadvisable,
+ "optional" => $optional,
+ "recommended" => $recommended,
+ "guided" => $guided,
+ "minimal" => $minimal,
+ "null" => $null
+);
+
+sub get_global_variable_value {
+ my ($variable) = @_;
+
+ my @known_variables = keys %global_variable_hash;
+ if (member($variable, @known_variables) + 1) {
+ if ($global_variable_hash{$variable}) {
+ return $global_variable_hash{$variable};
+ }
+ } else {
+ my $logger = get_logger();
+ $logger->error("No Tweaker Definition for variable named $variable");
+ return $bottom;
+ }
+}
+
+1;