summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tweaker/tweaker.install
diff options
context:
space:
mode:
authorJames Meyer <James.meyer@operamail.com>2009-02-07 19:01:21 (GMT)
committerJames Meyer <James.meyer@operamail.com>2009-02-07 19:01:21 (GMT)
commit2ee6cf133acb178f6f0bd880712431e74d63e557 (patch)
tree97f8c830ca3033427ed135159695b1142c6c6824 /abs/core-testing/tweaker/tweaker.install
parent096b016164d6231d9c323bbcfb0ac68789740ea9 (diff)
downloadlinhes_pkgbuild-2ee6cf133acb178f6f0bd880712431e74d63e557.zip
linhes_pkgbuild-2ee6cf133acb178f6f0bd880712431e74d63e557.tar.gz
linhes_pkgbuild-2ee6cf133acb178f6f0bd880712431e74d63e557.tar.bz2
Changes to tweaker PKGBUILD so that the pkg is built.
Have not tested tweaker beyond running tweaker.pl
Diffstat (limited to 'abs/core-testing/tweaker/tweaker.install')
-rw-r--r--abs/core-testing/tweaker/tweaker.install39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core-testing/tweaker/tweaker.install b/abs/core-testing/tweaker/tweaker.install
new file mode 100644
index 0000000..fc4ba07
--- /dev/null
+++ b/abs/core-testing/tweaker/tweaker.install
@@ -0,0 +1,39 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+/bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ touch /var/log/tweaker.log
+ chmod 777 /var/log/tweaker.log
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ /bin/true
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*