summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tweaker
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-07-13 21:50:14 (GMT)
committerBob Igo <bob@stormlogic.com>2009-07-13 21:50:14 (GMT)
commit4c71823825d08c1cc2219d22a6d3fe190e158a09 (patch)
tree66d53012b1510841c4a456b3db68ffdab5923b72 /abs/core-testing/tweaker
parent8ab2b94c697866402266afc4f04cebf76203463f (diff)
downloadlinhes_pkgbuild-4c71823825d08c1cc2219d22a6d3fe190e158a09.zip
linhes_pkgbuild-4c71823825d08c1cc2219d22a6d3fe190e158a09.tar.gz
linhes_pkgbuild-4c71823825d08c1cc2219d22a6d3fe190e158a09.tar.bz2
fixed twk_audio.pl bug
Diffstat (limited to 'abs/core-testing/tweaker')
-rw-r--r--abs/core-testing/tweaker/PKGBUILD2
-rwxr-xr-xabs/core-testing/tweaker/bin/twk_audio.pl10
2 files changed, 10 insertions, 2 deletions
diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index 377edda..b3b4983 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=tweaker
pkgver=1
-pkgrel=40
+pkgrel=41
pkgdesc="applies tweaks to the baseline configuration and attempts to optimize settings for the hardware it finds"
arch=('i686' 'x86_64')
diff --git a/abs/core-testing/tweaker/bin/twk_audio.pl b/abs/core-testing/tweaker/bin/twk_audio.pl
index 09676ed..47a2415 100755
--- a/abs/core-testing/tweaker/bin/twk_audio.pl
+++ b/abs/core-testing/tweaker/bin/twk_audio.pl
@@ -133,7 +133,7 @@ sub implement_option {
# Not supported yet.
}
case "digital" {
- $command2 = "echo -e 'ac=hwac3,hwdts, #TWEAKER\nao=alsa:device=plughw=$card.$device #TWEAKER\naf=scaletempo=stride=30:overlap=.50:search=10 #TWEAKER\nspeed=1.0 #TWEAKER' >> $mplayer_conf";
+ $command2 = "echo -e 'ac=hwac3,hwdts, #TWEAKER\nao=alsa:device=plughw=$card.$device #TWEAKER' >> $mplayer_conf";
if (my $error = execute_shell_command($command2)) {
$logger->error("ERROR: $error");
$logger->error("ERROR: Unable to implement option $option.");
@@ -160,6 +160,14 @@ sub implement_option {
}
}
}
+ # for all options
+ $command2 = "echo -e 'af=scaletempo=stride=30:overlap=.50:search=10 #TWEAKER\nspeed=1.0 #TWEAKER' >> $mplayer_conf";
+ if (my $error = execute_shell_command($command2)) {
+ $logger->error("ERROR: $error");
+ $logger->error("ERROR: Unable to implement option $option.");
+ exit(-1);
+ }
+
$logger->info("Edited $mplayer_conf for $option audio.");
}