summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tweaker
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-07-08 19:21:16 (GMT)
committerBob Igo <bob@stormlogic.com>2009-07-08 19:21:16 (GMT)
commitb8c1ca11b76f3d32e9680dfd1cbb611f000f7382 (patch)
treef5d2e3917175c3fe57165c42e4487855e516001f /abs/core-testing/tweaker
parent859a5850bb91c669554dee1a9210db8ad6396ab5 (diff)
downloadlinhes_pkgbuild-b8c1ca11b76f3d32e9680dfd1cbb611f000f7382.zip
linhes_pkgbuild-b8c1ca11b76f3d32e9680dfd1cbb611f000f7382.tar.gz
linhes_pkgbuild-b8c1ca11b76f3d32e9680dfd1cbb611f000f7382.tar.bz2
In R6, twk_graphics.pl can catch the wrong output from glxgears.
Diffstat (limited to 'abs/core-testing/tweaker')
-rw-r--r--abs/core-testing/tweaker/PKGBUILD2
-rwxr-xr-xabs/core-testing/tweaker/bin/twk_graphics.pl2
2 files changed, 2 insertions, 2 deletions
diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index 9c9b54a..5f92817 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=tweaker
pkgver=1
-pkgrel=33
+pkgrel=34
pkgdesc=""
arch=('i686' 'x86_64')
diff --git a/abs/core-testing/tweaker/bin/twk_graphics.pl b/abs/core-testing/tweaker/bin/twk_graphics.pl
index 4fb6d77..22b6688 100755
--- a/abs/core-testing/tweaker/bin/twk_graphics.pl
+++ b/abs/core-testing/tweaker/bin/twk_graphics.pl
@@ -43,7 +43,7 @@ sub check_for_GL() {
# Now poll the strength, returning the FPS from glxgears, run at the default resolution.
# I would love to be able to poll this in a way that 1) doesn't pop up a GUI window and
# 2) doesn't rely on manually making a database that maps video cards to performance levels.
- $result = execute_shell_command("script -q -c \"glxgears -fullscreen & sleep 11 ; pkill -15 glxgears\" | tail -1");
+ $result = execute_shell_command("script -q -c \"glxgears -fullscreen & sleep 11 ; pkill -15 glxgears\" | grep FPS | tail -1");
if ($result =~ m/ (\d+)\.\d+ FPS/) {
$fps = $1;
execute_shell_command("echo $fps > /tmp/fps");