summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/wpa_supplicant
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 18:32:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 18:32:21 (GMT)
commit14beb839185f027cba412b6aa0941296a843818b (patch)
tree1f3da37aafb017b95e6d326d5253a7230d4f39b1 /abs/core-testing/wpa_supplicant
parentc361f5eb42fcfcfa0663cb89c38b2eb8fab1bb2c (diff)
downloadlinhes_pkgbuild-14beb839185f027cba412b6aa0941296a843818b.zip
linhes_pkgbuild-14beb839185f027cba412b6aa0941296a843818b.tar.gz
linhes_pkgbuild-14beb839185f027cba412b6aa0941296a843818b.tar.bz2
Updating wpa_supplicant
Diffstat (limited to 'abs/core-testing/wpa_supplicant')
-rw-r--r--abs/core-testing/wpa_supplicant/PKGBUILD35
-rw-r--r--abs/core-testing/wpa_supplicant/config4
2 files changed, 23 insertions, 16 deletions
diff --git a/abs/core-testing/wpa_supplicant/PKGBUILD b/abs/core-testing/wpa_supplicant/PKGBUILD
index 2f022ce..2f6d45b 100644
--- a/abs/core-testing/wpa_supplicant/PKGBUILD
+++ b/abs/core-testing/wpa_supplicant/PKGBUILD
@@ -1,13 +1,14 @@
# Contributor: iztok pizorn <pizorn@gmail.com>
# Contributor: William Rea <sillywilly@gmail.com>
pkgname=wpa_supplicant
-pkgver=0.5.10
+pkgver=0.5.11
_madwifi_ver=0.9.4
-pkgrel=10
+pkgrel=1
pkgdesc="A utility providing key negotiation for WPA wireless networks"
arch=('i686' 'x86_64')
-makedepends=('kernel26>=2.6.24' 'kernel26<=2.6.26.3')
-depends=('openssl')
+makedepends=('kernel26>=2.6.28' 'kernel26<2.6.29')
+depends=('openssl' 'dbus-core>=1.2.4')
+optdepends=('wpa_supplicant_gui: wpa_gui program')
license=('GPL')
groups=('base')
backup=('etc/wpa_supplicant.conf')
@@ -15,22 +16,28 @@ url="http://hostap.epitest.fi/wpa_supplicant"
source=(http://hostap.epitest.fi/releases/wpa_supplicant-$pkgver.tar.gz
config
http://downloads.sourceforge.net/sourceforge/madwifi/madwifi-${_madwifi_ver}.tar.gz)
-install='wpa_supplicant.install'
-md5sums=('9e7b99da67c47d81121368c6d580d069'
- '87a7bb38e0b4820b29065a9b3e8f4e06'
+md5sums=('ad320af63f735531878e592f1ffd9b06'
+ '94fb8071fc440dca8294c9591486921f'
'399d20de8d855a59f20058857c2178ad')
build() {
- cd ${startdir}/src/
+ cd "${srcdir}"
mv madwifi-${_madwifi_ver} madwifi
- cd $startdir/src/$pkgname-$pkgver
+ cd "${srcdir}/${pkgname}-${pkgver}"
cp ../config ./.config
sed -i 's@/usr/local@$(PREFIX)@g' Makefile
sed -i 's@dynamic_eap_methods@@g' Makefile
make || return 1
- make PREFIX=/usr DESTDIR=$startdir/pkg install || return 1
- install -D -m644 wpa_supplicant.conf $startdir/pkg/etc/wpa_supplicant.conf || return 1
- install -d -m755 $startdir/pkg/usr/man/man{5,8} || return 1
- install -m644 doc/docbook/wpa_supplicant.conf.5 $startdir/pkg/usr/man/man5 || return 1
- install -m644 doc/docbook/{wpa_background,wpa_cli,wpa_passphrase,wpa_supplicant}.8 $startdir/pkg/usr/man/man8 || return 1
+ make PREFIX=/usr DESTDIR="${pkgdir}" install || return 1
+ install -m755 -d "${pkgdir}/etc"
+ install -m644 wpa_supplicant.conf "${pkgdir}/etc/wpa_supplicant.conf" || return 1
+ install -d -m755 ${pkgdir}/usr/share/man/man{5,8} || return 1
+ install -m644 doc/docbook/wpa_supplicant.conf.5 "${pkgdir}/usr/share/man/man5/" || return 1
+ install -m644 doc/docbook/{wpa_background,wpa_cli,wpa_passphrase,wpa_supplicant}.8 "${pkgdir}/usr/share/man/man8/" || return 1
+
+ install -m755 -d "${pkgdir}/usr/share/dbus-1/system-services"
+ install -m644 dbus-wpa_supplicant.service "${pkgdir}/usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service" || return 1
+ sed -e 's/sbin/usr\/sbin/' -i "${pkgdir}/usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service" || return 1
+ install -m755 -d "${pkgdir}/etc/dbus-1/system.d"
+ install -m644 dbus-wpa_supplicant.conf "${pkgdir}/etc/dbus-1/system.d/fi.epitest.hostap.WPASupplicant.conf" || return 1
}
diff --git a/abs/core-testing/wpa_supplicant/config b/abs/core-testing/wpa_supplicant/config
index 8841fe3..6ca1d3e 100644
--- a/abs/core-testing/wpa_supplicant/config
+++ b/abs/core-testing/wpa_supplicant/config
@@ -273,7 +273,7 @@ CONFIG_PEERKEY=y
#PLATFORMSDKLIB="/opt/Program Files/Microsoft Platform SDK/Lib"
# Add support for DBus control interface
-#CONFIG_CTRL_IFACE_DBUS=y
+CONFIG_CTRL_IFACE_DBUS=y
# Add support for loading EAP methods dynamically as shared libraries.
# When this option is enabled, each EAP method can be either included
@@ -304,5 +304,5 @@ CONFIG_DYNAMIC_EAP_METHODS=y
# to be able to include some of the kernel header files. Following lines can
# be used to set these (WIRELESS_DEV must point to the root directory of the
# wireless-dev.git tree).
-WIRELESS_DEV=/lib/modules/2.6.24-ARCH/build
+WIRELESS_DEV=/lib/modules/2.6.27-ARCH/build
CFLAGS += -I$(WIRELESS_DEV)/net/mac80211