summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/yasm
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-14 18:38:20 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-14 18:38:20 (GMT)
commit75a974500de1bb4b0bb84b726a9d7075d07e18b7 (patch)
tree9a0c45226e4b04a8595fbacfcde115d444f5c5d5 /abs/core-testing/yasm
parent14beb839185f027cba412b6aa0941296a843818b (diff)
downloadlinhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.zip
linhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.tar.gz
linhes_pkgbuild-75a974500de1bb4b0bb84b726a9d7075d07e18b7.tar.bz2
Removing more cross repo makedepends.
Moved the following packages from extra->core. nasm automake autoconf sharutils imake gperf/ yasm/ setuptools/ libcaca/ libdca/ live-media/ There are still several cross repo make depends, but some packages just dont' belong in core. For instance avahi and ca-certificates(core) depend on mono and ruby(extra). But really mono and ruby do not belong in core.
Diffstat (limited to 'abs/core-testing/yasm')
-rw-r--r--abs/core-testing/yasm/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core-testing/yasm/PKGBUILD b/abs/core-testing/yasm/PKGBUILD
new file mode 100644
index 0000000..fcbd935
--- /dev/null
+++ b/abs/core-testing/yasm/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 18746 2008-11-08 22:44:05Z aaron $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Vinay S Shastry <vinayshastry@gmail.com>
+
+pkgname=yasm
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="A rewrite of NASM to allow for multiple syntax supported (NASM, TASM, GAS, etc.)"
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.tortall.net/projects/yasm/"
+depends=('glibc')
+source=(http://www.tortall.net/projects/yasm/releases/$pkgname-$pkgver.tar.gz)
+options=('!libtool')
+md5sums=('cc9360593de5625dca286f0bfcb27dd5')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -Dm644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+}