summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-31 16:41:27 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-31 16:41:27 (GMT)
commit47758fbaab37b8505c3b5d02c1037e7b64a05bd8 (patch)
tree2917183eb9720ebfb941977683f73b5e411443c4 /abs/core-testing
parentb9d83d0059190237b1436c4998251e92078f17cb (diff)
downloadlinhes_pkgbuild-47758fbaab37b8505c3b5d02c1037e7b64a05bd8.zip
linhes_pkgbuild-47758fbaab37b8505c3b5d02c1037e7b64a05bd8.tar.gz
linhes_pkgbuild-47758fbaab37b8505c3b5d02c1037e7b64a05bd8.tar.bz2
create initial media_dir pkg
Create /myth/*
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/media_dirs/PKGBUILD68
-rw-r--r--abs/core-testing/media_dirs/media_dirs.install42
2 files changed, 110 insertions, 0 deletions
diff --git a/abs/core-testing/media_dirs/PKGBUILD b/abs/core-testing/media_dirs/PKGBUILD
new file mode 100644
index 0000000..f3907fe
--- /dev/null
+++ b/abs/core-testing/media_dirs/PKGBUILD
@@ -0,0 +1,68 @@
+pkgname=media_dirs
+pkgver=1
+pkgrel=12
+pkgdesc="creates the dir layout for mythtv to use"
+url=""
+license=""
+depends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=media_dirs.install
+provides=()
+source=()
+md5sums=()
+arch=('i686')
+
+
+build() {
+ cd $startdir/src/
+ DIR_PREFIX=myth
+ while read dirname
+ do
+ mkdir -p "$startdir/src/$DIR_PREFIX/${dirname}"
+ touch "$startdir/src/$DIR_PREFIX/${dirname}/.media"
+ done <<EOF
+tv
+gallery
+music
+games/nes/roms
+games/nes/screens
+games/nes
+games/pc/screens
+games/pc
+games/snes/roms
+games/snes/screens
+games/snes
+games/xmame/cabs
+games/xmame/flyers
+games/xmame/hiscores
+games/xmame/history
+games/xmame/roms
+games/xmame/screens
+games/xmame
+games
+backup
+image_cache
+video/.covers
+video/archive
+video
+motion
+tmp
+archive
+stream
+phone/Voicemail
+phone/Photos
+phone
+pretty
+EOF
+
+
+ chown -R mythtv myth
+ chmod -R 777 myth
+ cp -rp myth $startdir/pkg/
+ cd $startdir/pkg
+
+}
+
diff --git a/abs/core-testing/media_dirs/media_dirs.install b/abs/core-testing/media_dirs/media_dirs.install
new file mode 100644
index 0000000..c709d79
--- /dev/null
+++ b/abs/core-testing/media_dirs/media_dirs.install
@@ -0,0 +1,42 @@
+# This is a default template for a post-install scriptlet. You can
+# remove any functions you don't need (and this header).
+
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+ }
+
+ # arg 1: the new package version
+ post_install() {
+ chown -R mythtv:users /myth
+ # ln -s /myth /data/media
+
+
+ }
+
+ # arg 1: the new package version
+ # arg 2: the old package version
+ pre_upgrade() {
+ /bin/true
+ }
+
+ # arg 1: the new package version
+ # arg 2: the old package version
+ post_upgrade() {
+ /bin/true
+ post_install
+ }
+
+ # arg 1: the old package version
+ pre_remove() {
+ /bin/true
+ }
+
+ # arg 1: the old package version
+ post_remove() {
+ /bin/true
+ }
+
+ op=$1
+ shift
+ $op $*