summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-01-08 03:25:11 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-01-08 03:25:11 (GMT)
commit99d3b01af539881a92ff4ae8a1fda0dbfc7cfaa7 (patch)
tree5c2d1cfd6e5f1f61d02a3c8b661202afb6b36066 /abs/core-testing
parent53247f3bab6eb7210e1dc9a10c8f2b5cebefcd54 (diff)
downloadlinhes_pkgbuild-99d3b01af539881a92ff4ae8a1fda0dbfc7cfaa7.zip
linhes_pkgbuild-99d3b01af539881a92ff4ae8a1fda0dbfc7cfaa7.tar.gz
linhes_pkgbuild-99d3b01af539881a92ff4ae8a1fda0dbfc7cfaa7.tar.bz2
Remove writing boot sector from the progress log.
Also stop the Progress dialog from ever reaching 100% complete. closes FS#78
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/install_proxy.sh24
2 files changed, 14 insertions, 12 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index c0eaf2b..44cb38a 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=1.0
-pkgrel=149
+pkgrel=152
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index 8462e9c..e29417e 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -124,14 +124,15 @@ full_install () {
$run copy_it $disk ALL
rm $mountpoint/etc/fstab
$run fstab_fix_it $disk $rootfs $datafs FULL_INSTALL
-
- progress 99
+ echo "Configuring system" > /tmp/.install_state
+ progress 100
+ #progress 99
sleep 1
$run grub_it $disk
- echo "Configuring system" > /tmp/.install_state
- progress 100
+ #echo "Configuring system" > /tmp/.install_state
+ #progress 100
sleep 1
cp_and_log /etc/systemconfig "$mountpoint"/etc
#run save syssettings to save settings, then copy to new mountpoint
@@ -264,13 +265,14 @@ function upgrade () {
#this is here to copy in the systemconfig file as soon as possible.
cp_and_log /etc/systemconfig "$mountpoint"/etc/systemconfig
-
- echo "Writing boot sector" > /tmp/.install_state
- progress 99
+ echo "Configuring system" > /tmp/.install_state
+ progress 100
+ #echo "Writing boot sector" > /tmp/.install_state
+ #progress 99
sleep 1
$run grub_it $disk
- echo "Configuring system" > /tmp/.install_state
- progress
+ #echo "Configuring system" > /tmp/.install_state
+ #progress 100
sleep 1
cp_and_log /etc/mtab "$mountpoint"/etc/mtab
cp_and_log /etc/systemconfig "$mountpoint"/etc
@@ -602,10 +604,10 @@ echo "-----------------------------------------------------------------------3--
total=$TOTALSIZE
fi
percent=`echo "scale=2 ; ($used/$total) * 100 " |bc `
- cond2=$(echo "$percent > 100" |bc )
+ cond2=$(echo "$percent > 98" |bc )
if [ $cond2 -eq 1 ]
then
- percent=100
+ percent=98
fi
cond3=$(echo "$percent < 3" |bc )
if [ $cond3 -eq 0 ]