summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-08-30 01:29:53 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-08-30 01:29:53 (GMT)
commita56552217f33d3ce4d72d65ca19056d45858a4ee (patch)
tree1dd5fe05379306ad4b0683b65e9da9db7c4a961f /abs/core-testing
parente179d165396f026fa6053c6c055d00d16b5eb141 (diff)
downloadlinhes_pkgbuild-a56552217f33d3ce4d72d65ca19056d45858a4ee.zip
linhes_pkgbuild-a56552217f33d3ce4d72d65ca19056d45858a4ee.tar.gz
linhes_pkgbuild-a56552217f33d3ce4d72d65ca19056d45858a4ee.tar.bz2
LinHES-config mythinstall foldingathome: initial inclusion of Folding@home
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/mv_software.py6
-rw-r--r--abs/core-testing/mythinstall/PKGBUILD3
-rwxr-xr-xabs/core-testing/mythinstall/installsettings.cpp72
-rwxr-xr-xabs/core-testing/mythinstall/installsettings.h3
-rwxr-xr-xabs/core-testing/mythinstall/xorgsettings.h3
6 files changed, 77 insertions, 12 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index cbe41ab..de4e94b 100644
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=89
+pkgrel=90
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted
diff --git a/abs/core-testing/LinHES-config/mv_software.py b/abs/core-testing/LinHES-config/mv_software.py
index 7421e08..0a96bb3 100755
--- a/abs/core-testing/LinHES-config/mv_software.py
+++ b/abs/core-testing/LinHES-config/mv_software.py
@@ -19,7 +19,7 @@ def setup_software(systemconfig, data_config):
default_installed=("mythcontrols", "mythgallery", "mythmovies",
"mythmusic", "mythsmolt", "mythvideo")
- other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "mythappletrailers", "mythstream", "mythvodka")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome", "mythappletrailers", "mythstream", "mythvodka")
else:
default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
"mythgame", "mythflix", "mythweather",
@@ -27,7 +27,7 @@ def setup_software(systemconfig, data_config):
default_installed=("mythcontrols", "mythgallery", "mythmovies",
"mythmusic", "mythsmolt", "mythvideo")
- other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "foldingathome")
for pkg in default_disabled:
pkgname=pkg+postfix
@@ -56,4 +56,4 @@ def setup_software(systemconfig, data_config):
mv_common.pacremove(pkg)
except:
logging.debug(" ERROR-- %s is not defined", pkg)
- logging.info("__End Software\n ") \ No newline at end of file
+ logging.info("__End Software\n ")
diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index 75654f1..c614fac 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=1
-pkgrel=9
+pkgrel=10
pkgdesc="LinHES installer/systemconfig GUI."
arch=i686
depends=()
@@ -47,4 +47,3 @@ build() {
ln -s MythVantage mythinstall
cd -
}
-
diff --git a/abs/core-testing/mythinstall/installsettings.cpp b/abs/core-testing/mythinstall/installsettings.cpp
index 7315464..3942460 100755
--- a/abs/core-testing/mythinstall/installsettings.cpp
+++ b/abs/core-testing/mythinstall/installsettings.cpp
@@ -1277,6 +1277,62 @@ static HostCheckBox *Hostfuppes()
return gc;
};
+static HostCheckBox *Hostfoldingathome()
+{
+ HostCheckBox *gc = new HostCheckBox("Hostfoldingathome");
+ gc->setLabel(QObject::tr("Folding@home"));
+ gc->setValue(false);
+ gc->setHelpText(QObject::tr("A distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."));
+ return gc;
+};
+
+static HostComboBox *Hostfoldingusername()
+{
+ // If there is an old R5.5 style folding directory /myth/folding@home, attempt
+ // to retrieve the old username.
+
+ FILE *username_pipe;
+ username_pipe =
+ popen (
+ "grep username= /myth/folding@home/client.cfg 2> /dev/null | "
+ "sed 's/username=//g'", "r");
+
+ if (username_pipe)
+ {
+ char username[200];
+ if (fgets (username, sizeof (username), username_pipe))
+ {
+ char *new_line;
+ username[sizeof(username)-1]=0;
+ if ((new_line = strchr (username, '\n')))
+ new_line[0] = 0;
+
+ cout << "found old username " << username << endl;
+
+ gContext->SetSetting("Hostfoldingusername", username);
+ gContext->SaveSetting("Hostfoldingusername", username);
+ }
+ pclose (username_pipe);
+ }
+
+ HostComboBox *gc = new HostComboBox("Hostfoldingusername",true);
+ gc->setLabel(QObject::tr("Folding Username"));
+ gc->setValue("");
+
+ gc->setHelpText(QObject::tr("The username associated to the work-units you return."));
+ return gc;
+};
+
+static HostComboBox *Hostfoldingworksize()
+{
+ HostComboBox *gc = new HostComboBox("Hostfoldingworksize");
+ gc->setLabel(QObject::tr("Work Packet Size"));
+ gc->addSelection("Big", "big");
+ gc->addSelection("Normal", "normal");
+ gc->addSelection("Small", "small");
+ gc->setHelpText(QObject::tr("Acceptable size of work assignment and work result packets (bigger units may have large memory demands)."));
+ return gc;
+};
static HostCheckBox *HostXscreensaver()
{
@@ -3880,6 +3936,9 @@ void writesettings ()
hostparm.ThisHostXine = gContext->GetSetting("HostXine");
hostparm.ThisHostwebmin = gContext->GetSetting("Hostwebmin");
hostparm.ThisHostfuppes = gContext->GetSetting("Hostfuppes");
+ hostparm.ThisHostfoldingathome = gContext->GetSetting("Hostfoldingathome");
+ hostparm.ThisHostfoldingusername = gContext->GetSetting("Hostfoldingusername");
+ hostparm.ThisHostfoldingworksize = gContext->GetSetting("Hostfoldingworksize");
hostparm.ThisHostDDnslogin = gContext->GetSetting("HostDDnslogin");
hostparm.ThisHostDDnspassword = gContext->GetSetting("HostDDnspassword");
hostparm.ThisHostDDnshostname = gContext->GetSetting("HostDDnshostname");
@@ -4124,7 +4183,9 @@ void writesettings ()
myfile << "xine=\"" + hostparm.ThisHostXine + "\"\n";
myfile << "webmin=\"" + hostparm.ThisHostwebmin + "\"\n";
myfile << "fuppes=\"" + hostparm.ThisHostfuppes + "\"\n";
-
+ myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome + "\"\n";
+ myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername + "\"\n";
+ myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize + "\"\n";
@@ -4378,6 +4439,10 @@ MythInstallSettings::MythInstallSettings()
ConfigurationGroup *GridShowPlugin5 = new GridConfigurationGroup(2);
GridShowPlugin5->addChild(Hostfuppes());
+ ConfigurationGroup *GridShowPlugin6 = new VerticalConfigurationGroup(true,true);
+ GridShowPlugin6->addChild(Hostfoldingathome());
+ GridShowPlugin6->addChild(Hostfoldingusername());
+ GridShowPlugin6->addChild(Hostfoldingworksize());
ConfigurationGroup *Mythvideoplugin = new HorizontalConfigurationGroup();
Mythvideoplugin->addChild(Hostpluginmythvideo());
@@ -4395,6 +4460,7 @@ MythInstallSettings::MythInstallSettings()
addChild(GridShowPlugin3);
addChild(GridShowPlugin4);
addChild(GridShowPlugin5);
+ addChild(GridShowPlugin6);
}
}
if ( displayuser )
@@ -4475,7 +4541,3 @@ MythInstallSettings::MythInstallSettings()
};
-
-
-
-
diff --git a/abs/core-testing/mythinstall/installsettings.h b/abs/core-testing/mythinstall/installsettings.h
index 55203f0..c140f3d 100755
--- a/abs/core-testing/mythinstall/installsettings.h
+++ b/abs/core-testing/mythinstall/installsettings.h
@@ -455,6 +455,9 @@ struct HostParms
QString ThisHostXine;
QString ThisHostwebmin;
QString ThisHostfuppes;
+ QString ThisHostfoldingathome;
+ QString ThisHostfoldingusername;
+ QString ThisHostfoldingworksize;
QString ThisHostDDnslogin;
QString ThisHostDDnspassword;
diff --git a/abs/core-testing/mythinstall/xorgsettings.h b/abs/core-testing/mythinstall/xorgsettings.h
index 4a4ed34..46c4952 100755
--- a/abs/core-testing/mythinstall/xorgsettings.h
+++ b/abs/core-testing/mythinstall/xorgsettings.h
@@ -152,7 +152,7 @@ static HostComboBox *HostXres()
if (strcmp (previous_mode, separator) == 0)
continue;
- strncpy (previous_mode, separator, 200);
+ strncpy (previous_mode, separator, sizeof(previous_mode));
gc->addSelection(separator, line_in);
found_modes_in_xorg_log = TRUE;
@@ -161,6 +161,7 @@ static HostComboBox *HostXres()
defaults_added[def]=1;
}
}
+ pclose (modelines);
}
}