summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2009-03-09 16:41:39 (GMT)
committerJames Meyer <james.meyer@operamail.com>2009-03-09 16:41:39 (GMT)
commita962fbdaa7253d70c1e0d104eb84886d2e5115b0 (patch)
treedbb43f8a00ebf26a0d2dd2364629e94ec4f3362c /abs/core-testing
parent84cfad2c9cd6bba15d84e31ee927f339cd9b1ff6 (diff)
downloadlinhes_pkgbuild-a962fbdaa7253d70c1e0d104eb84886d2e5115b0.zip
linhes_pkgbuild-a962fbdaa7253d70c1e0d104eb84886d2e5115b0.tar.gz
linhes_pkgbuild-a962fbdaa7253d70c1e0d104eb84886d2e5115b0.tar.bz2
don't symlink if the links are already present
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/runit-scripts/PKGBUILD6
-rwxr-xr-xabs/core-testing/runit-scripts/runit.install20
2 files changed, 13 insertions, 13 deletions
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index 1b74888..619cfcf 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=34
+pkgrel=39
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
@@ -8,7 +8,7 @@ depends=('glibc' 'util-linux' 'initscripts' 'runit' )
makedepends=()
conflicts=()
replaces=()
-backup=()
+backup=(etc/runit/1.local)
install=runit.install
source=()
arch=('i686')
@@ -21,7 +21,7 @@ build() {
install -d $startdir/pkg/var/service
install -d $startdir/pkg/etc/sv
install -d $startdir/pkg/sbin
- install -m0700 1 2 3 ctrlaltdel $startdir/pkg/etc/runit
+ install -m0700 1 2 3 1.local ctrlaltdel $startdir/pkg/etc/runit
install -m0755 reboot-runit halt-runit logger $startdir/pkg/sbin
rsync -a --exclude=.svn services/* $startdir/pkg/etc/sv
diff --git a/abs/core-testing/runit-scripts/runit.install b/abs/core-testing/runit-scripts/runit.install
index 4b97199..1e3f619 100755
--- a/abs/core-testing/runit-scripts/runit.install
+++ b/abs/core-testing/runit-scripts/runit.install
@@ -29,11 +29,11 @@ post_install () {
ln -s /etc/sv/$i /var/service/$i
done
- ln -s /sbin/halt.script /sbin/halt
- ln -s /sbin/reboot.script /sbin/reboot
- ln -s /sbin/poweroff.script /sbin/poweroff
- ln -s /sbin/halt-init /sbin/reboot.init
- ln -s /sbin/halt-init /sbin/poweroff.init
+ [ -e /sbin/halt ] || ln -s /sbin/halt.script /sbin/halt
+ [ -e /sbin/reboot ] || ln -s /sbin/reboot.script /sbin/reboot
+ [ -e /sbin/poweroff ] || ln -s /sbin/poweroff.script /sbin/poweroff
+ [ -e /sbin/reboot.init ] || ln -s /sbin/halt-init /sbin/reboot.init
+ [ -e /sbin/poweroff.init ] || ln -s /sbin/halt-init /sbin/poweroff.init
}
@@ -42,12 +42,12 @@ post_install () {
# arg 2: the old package version
post_upgrade(){
- ln -s /sbin/halt.script /sbin/halt
- ln -s /sbin/reboot.script /sbin/reboot
- ln -s /sbin/poweroff.script /sbin/poweroff
- ln -s /sbin/halt-init /sbin/reboot.init
- ln -s /sbin/halt-init /sbin/poweroff.init
+ [ -e /sbin/halt ] || ln -s /sbin/halt.script /sbin/halt
+ [ -e /sbin/reboot ] || ln -s /sbin/reboot.script /sbin/reboot
+ [ -e /sbin/poweroff ] || ln -s /sbin/poweroff.script /sbin/poweroff
+ [ -e /sbin/reboot.init ] || ln -s /sbin/halt-init /sbin/reboot.init
+ [ -e /sbin/poweroff.init ] || ln -s /sbin/halt-init /sbin/poweroff.init
}
op=$1