summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 04:57:50 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2008-12-01 04:57:50 (GMT)
commitd615d8fb4dd78b2e51708b321ad77b6304458bfd (patch)
treeee1585afa44494632f0ebbee7c11e8c6ddf4fb52 /abs/core-testing
parente4e922e8206bce66217e08b678b10465036dd44c (diff)
parent982eaa1f1285ed3cb1022ec9520d1d6387b62e64 (diff)
downloadlinhes_pkgbuild-d615d8fb4dd78b2e51708b321ad77b6304458bfd.zip
linhes_pkgbuild-d615d8fb4dd78b2e51708b321ad77b6304458bfd.tar.gz
linhes_pkgbuild-d615d8fb4dd78b2e51708b321ad77b6304458bfd.tar.bz2
Merge branch 'HEAD' of ssh://cesman@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/install-ui.xml2
-rwxr-xr-xabs/core-testing/LinHES-config/install_proxy.sh4
-rwxr-xr-xabs/core-testing/LinHES-config/systemconfig.sh56
-rw-r--r--abs/core-testing/LinHES-config/templates/remotes/dvico/preview.jpgbin0 -> 15108 bytes
-rw-r--r--abs/core-testing/LinHES-config/templates/remotes/receiver_usb.id52
-rwxr-xr-xabs/core-testing/LinHES-config/xconfig.sh95
-rw-r--r--abs/core-testing/LinHES-system/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-system/firstboot.sh1
-rwxr-xr-xabs/core-testing/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core-testing/runit-scripts/runit.install3
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/frontend/run2
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/lircd/finish6
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/lircd/run1
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/ntpd/run4
-rwxr-xr-xabs/core-testing/runit/PKGBUILD2
-rwxr-xr-xabs/core-testing/runit/runit.install9
17 files changed, 118 insertions, 125 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 68dc6c8..86a3181 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=1.0
-pkgrel=34
+pkgrel=52
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan hwd)
diff --git a/abs/core-testing/LinHES-config/install-ui.xml b/abs/core-testing/LinHES-config/install-ui.xml
index b7a67de..2b3a043 100755
--- a/abs/core-testing/LinHES-config/install-ui.xml
+++ b/abs/core-testing/LinHES-config/install-ui.xml
@@ -17,7 +17,7 @@
<font name="title" face="Arial">
<color>#ffff00</color>
<dropcolor>#000000</dropcolor>
- <size>22</size>
+ <size>20</size>
<shadow>3,3</shadow>
<bold>yes</bold>
</font>
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index 57258da..f106b50 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -94,7 +94,7 @@ full_install () {
startsize=`statgrab -M disk.|grep $disk.write_bytes|cut -d= -f 2|tr -d " "`
echo "STARTSIZE=$startsize">/tmp/.startsize.io
- echo "Installing data" > /tmp/.install_state
+ echo "Creating $hostname" > /tmp/.install_state
sleep 1
$run copy_it $disk ALL
@@ -195,7 +195,7 @@ function upgrade () {
$run mount_it $disk
startsize=`statgrab -M disk.|grep $disk.write_bytes|cut -d= -f 2|tr -d " "`
echo "STARTSIZE=$startsize">/tmp/.startsize.io
- echo "Installing data" > /tmp/.install_state
+ echo "Creating $hostname" > /tmp/.install_state
sleep 1
cp -rf /tmp/etc /new_boot/etc.old
cp -rf /tmp/oss /new_boot/var/lib/oss.old
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index d84c0dc..6c72b92 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -191,7 +191,7 @@ function setupremote {
do
cat $i >> ${BASE}/etc/lircd.conf
done
- cp lircrc ${BASE}/etc/lircrc
+ cp -f lircrc* $BASE/etc/lircrc 2> /dev/null
if [ -f $TEMPLATES/LCD/$LCDtype/lircrc ]
then
cat $TEMPLATES/LCD/$LCDtype/lircrc >> /etc/lircrc
@@ -358,10 +358,10 @@ EOF
#this is used for backend or standlone types
if [ $1 = "1" ]
then
- echo "server ntp1.cs.wisc.edu" >> ${BASE}/etc/ntp.conf
- echo "server ntp3.sf-bay.org" >> ${BASE}/etc/ntp.conf
- echo "restrict ntp1.cs.wisc.edu noquery nomodify" >> ${BASE}/etc/ntp.conf
- echo "restrict ntp3.sf-bay.org noquery nomodify" >> ${BASE}/etc/ntp.conf
+ echo "server pool.ntp.org" >> ${BASE}/etc/ntp.conf
+ #echo "server ntp3.sf-bay.org" >> ${BASE}/etc/ntp.conf
+ echo "restrict pool.ntp.org" >> ${BASE}/etc/ntp.conf
+ #echo "restrict ntp3.sf-bay.org noquery nomodify" >> ${BASE}/etc/ntp.conf
else
echo "server $dbhost" >> ${BASE}/etc/ntp.conf
@@ -659,29 +659,29 @@ then
fi
#Setting the default, just to avoid the or statement..
-if [ x$UseHobbit = x ]
-then
- UseHobbit=0
-fi
-
-if [ x$UseHobbit = x1 ]
-then
- case $SystemType in
- Standalone|Master_backend )
- ser_daemon_add="hobbit $ser_daemon_add"
- ser_install="hobbitserver $ser_install"
- ;;
-
- *) ser_daemon_add="hobbit-client $ser_daemon_add"
- ser_install="hobbit-client $ser_install"
- ;;
- esac
-else
- ser_daemon_remove="hobbit hobbit-client $ser_daemon_remove"
- ser_remove="hobbit-client hobbitserver $ser_remove"
- rm -f /data/srv/httpd/htdocs/hobbit/index.html
-
- fi
+#if [ x$UseHobbit = x ]
+#then
+# UseHobbit=0
+#fi
+
+#if [ x$UseHobbit = x1 ]
+#then
+# case $SystemType in
+# Standalone|Master_backend )
+# ser_daemon_add="hobbit $ser_daemon_add"
+# ser_install="hobbitserver $ser_install"
+# ;;
+#
+# *) ser_daemon_add="hobbit-client $ser_daemon_add"
+# ser_install="hobbit-client $ser_install"
+# ;;
+# esac
+#else
+# ser_daemon_remove="hobbit hobbit-client $ser_daemon_remove"
+# ser_remove="hobbit-client hobbitserver $ser_remove"
+# rm -f /data/srv/httpd/htdocs/hobbit/index.html
+#
+# fi
diff --git a/abs/core-testing/LinHES-config/templates/remotes/dvico/preview.jpg b/abs/core-testing/LinHES-config/templates/remotes/dvico/preview.jpg
new file mode 100644
index 0000000..d2ccdd1
--- /dev/null
+++ b/abs/core-testing/LinHES-config/templates/remotes/dvico/preview.jpg
Binary files differ
diff --git a/abs/core-testing/LinHES-config/templates/remotes/receiver_usb.id b/abs/core-testing/LinHES-config/templates/remotes/receiver_usb.id
index 4070964..71b37d1 100644
--- a/abs/core-testing/LinHES-config/templates/remotes/receiver_usb.id
+++ b/abs/core-testing/LinHES-config/templates/remotes/receiver_usb.id
@@ -5,29 +5,29 @@
0e9c:0000|streamzap| "Streamzap Remote"
0fe9:9010|dvico| "DVICO Remote:"
6253:0100|Twinhan_USB| "the VisionPlus is a Twinhan clone "
-1509:9242|MCEUSB-new| "FIC eHome Infrared Transceiver 1509/9242"
-1934:0602|MCEUSB-new| "Fintek eHome Infrared Transceiver 1934/0602"
-147a:e015|MCEUSB-new| "Formosa eHome Infrared Transceiver 147a/e015"
-147a:e017|MCEUSB-new| "Formosa aim / Trust MCE Infrared Receiver147a/e017"
-147a:e018|MCEUSB-new| "Formosa Industrial Computing 147a/e018"
-107b:3009|MCEUSB-new| "Gateway eHome Infrared Transceiver 107b/3009"
-195d:7002|MCEUSB-new| "Itron ione Libra Q-11 195d/7002"
-043e:9803|MCEUSB-new| "LG eHome Infrared Transceiver 043e/9803"
-045e:00a0|MCEUSB-new| "Microsoft MCE Infrared Transceiver 045e/00a0"
-03ee:2501|MCEUSB-new| "Mitsumi 03ee/2501"
-0471:060c|MCEUSB-new| "Philips Infrared Transciever - HP branded 0471/060C"
-0471:060d|MCEUSB-new| "Philips SRM5100 0471/060d"
-0471:0815|MCEUSB-new| "Philips eHome Infrared Transciever 0471/0815"
-2304:0225|MCEUSB-new| "Pinnacle Systems, Inc. 2304/0225"
-179d:0010|MCEUSB-new| "Ricavision internal Infrared Transceiver 179d/0010"
-1308:c001|MCEUSB-new| "Shuttle eHome Infrared Transceiver 1308/c001"
-051c:c001|MCEUSB-new| "Shuttle2 eHome Infrared Transceiver 051c/c001"
-0609:031d|MCEUSB-new| "SMK/Toshiba G83C0004D410 0609/031d"
-0609:0322|MCEUSB-new| "SMK eHome Infrared Transceiver (Sony VAIO)0609/0322"
-0609:0334|MCEUSB-new| "SKM bundled with Hauppauge PVR-150 0609/0334"
-1460:9150|MCEUSB-new| "Tatung eHome Infrared Transceiver 1460/9150"
-1784:0001|MCEUSB-new| "Topseed eHome Infrared Transceiver 1784/0001"
-1784:0006|MCEUSB-new| "Topseed HP eHome Infrared Transceiver 1784/0006"
-1784:0007|MCEUSB-new| "Topseed HP eHome Infrared Transceiver 1784/0007"
-1784:0008|MCEUSB-new| "Topseed eHome Infrared Transceiver 1784/0008"
-045e:006d|MCEUSB-old| "USB Microsoft IR Transceiver Driver 045e/006d"
+1509:9242|mceusb| "FIC eHome Infrared Transceiver 1509/9242"
+1934:0602|mceusb| "Fintek eHome Infrared Transceiver 1934/0602"
+147a:e015|mceusb| "Formosa eHome Infrared Transceiver 147a/e015"
+147a:e017|mceusb| "Formosa aim / Trust MCE Infrared Receiver147a/e017"
+147a:e018|mceusb| "Formosa Industrial Computing 147a/e018"
+107b:3009|mceusb| "Gateway eHome Infrared Transceiver 107b/3009"
+195d:7002|mceusb| "Itron ione Libra Q-11 195d/7002"
+043e:9803|mceusb| "LG eHome Infrared Transceiver 043e/9803"
+045e:00a0|mceusb| "Microsoft MCE Infrared Transceiver 045e/00a0"
+03ee:2501|mceusb| "Mitsumi 03ee/2501"
+0471:060c|mceusb| "Philips Infrared Transciever - HP branded 0471/060C"
+0471:060d|mceusb| "Philips SRM5100 0471/060d"
+0471:0815|mceusb| "Philips eHome Infrared Transciever 0471/0815"
+2304:0225|mceusb| "Pinnacle Systems, Inc. 2304/0225"
+179d:0010|mceusb| "Ricavision internal Infrared Transceiver 179d/0010"
+1308:c001|mceusb| "Shuttle eHome Infrared Transceiver 1308/c001"
+051c:c001|mceusb| "Shuttle2 eHome Infrared Transceiver 051c/c001"
+0609:031d|mceusb| "SMK/Toshiba G83C0004D410 0609/031d"
+0609:0322|mceusb| "SMK eHome Infrared Transceiver (Sony VAIO)0609/0322"
+0609:0334|mceusb| "SKM bundled with Hauppauge PVR-150 0609/0334"
+1460:9150|mceusb| "Tatung eHome Infrared Transceiver 1460/9150"
+1784:0001|mceusb| "Topseed eHome Infrared Transceiver 1784/0001"
+1784:0006|mceusb| "Topseed HP eHome Infrared Transceiver 1784/0006"
+1784:0007|mceusb| "Topseed HP eHome Infrared Transceiver 1784/0007"
+1784:0008|mceusb| "Topseed eHome Infrared Transceiver 1784/0008"
+045e:006d|mceusb-old| "USB Microsoft IR Transceiver Driver 045e/006d"
diff --git a/abs/core-testing/LinHES-config/xconfig.sh b/abs/core-testing/LinHES-config/xconfig.sh
index 4984dc5..39b5ae6 100755
--- a/abs/core-testing/LinHES-config/xconfig.sh
+++ b/abs/core-testing/LinHES-config/xconfig.sh
@@ -8,9 +8,9 @@ function Xvalues {
echo $CMDLINE |grep -q forceXvesa
if [ $? = 0 ]
then
- VGACARDTYPE=vesa
+ VGACARDTYPE=vesa
else
- VGACARDTYPE=`lspci|grep -i vga|sort -r|head -n 1| cut -d: -f3|cut -d" " -f 2`
+ VGACARDTYPE=`lspci|grep -i vga|sort -r|head -n 1| cut -d: -f3|cut -d" " -f 2`
fi
echo $VGACARDTYPE
currentmode=`cat $BASE/etc/X11/xorg.conf |grep Modes|awk -Fs ' { print $2 } '`
@@ -28,12 +28,12 @@ then
else
echo "Didn't find the file"
echo "Copy your config file to $BASE/data/home/mythtv/templates/xorg.use " >> $XORG_CONF
- fi
+ fi
else
setupAdvancedX
fi
else
- setupX
+ setupX
fi
}
@@ -65,27 +65,27 @@ echo "#doing the advanced" > /tmp/options
ML="\t Modes ${Xres}"
else
- ML="\t Modes \"${Xres}\""
+ ML="\t Modes \"${Xres}\""
fi
echo $ML
case $Xcardtype in
NVIDIA|nVidia )
- case $Xconnection in
+ case $Xconnection in
DVI) ConnectedMonitor=DFP ;;
vga) ConnectedMonitor=CRT;;
Auto) ConnectedMonitor=Auto;;
TV) ConnectedMonitor=TV
- echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
- echo "Option \"TVOutFormat\" \"$XTVconnection\"" >> /tmp/options
- ;;
+ echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
+ echo "Option \"TVOutFormat\" \"$XTVconnection\"" >> /tmp/options
+ ;;
esac
if [ $ConnectedMonitor = Auto ]
then
- echo "auto connection"
+ echo "auto connection"
else
- echo "Option \"ConnectedMonitor\" \"$ConnectedMonitor\"" >> /tmp/options
- echo "Option \"FlatPanelProperties\" \"Scaling = centered, Dithering = enabled\"" >> /tmp/options
+ echo "Option \"ConnectedMonitor\" \"$ConnectedMonitor\"" >> /tmp/options
+ echo "Option \"FlatPanelProperties\" \"Scaling = centered, Dithering = enabled\"" >> /tmp/options
echo "Option \"DigitalVibrance\" \"0\"" >> /tmp/options
fi
@@ -96,7 +96,7 @@ echo "#doing the advanced" > /tmp/options
DS=" DisplaySize $XDisplaysize"
HS=" HorizSync $XHsync"
VR=" VertRefresh $XVrefresh"
- else
+ else
EDIDvalue=false
EDIDFREQ=true
DS="# Display size edid used "
@@ -109,46 +109,46 @@ echo "#doing the advanced" > /tmp/options
sed -e "s/^.*Modes.*$/${ML}/" \
- -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
- -e "s/^.*DisplaySize.*$/ $DS/" \
- -e "s/^#.*HorizSync.*$/ $HS/g" \
- -e "s/^#.*VertRefresh.*$/ $VR/g" \
- -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.nvidia > $XORG_CONF
-
- ;;
- ati|ATI)
- case $Xconnection in
+ -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
+ -e "s/^.*DisplaySize.*$/ $DS/" \
+ -e "s/^#.*HorizSync.*$/ $HS/g" \
+ -e "s/^#.*VertRefresh.*$/ $VR/g" \
+ -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.nvidia > $XORG_CONF
+
+ ;;
+ ati|ATI)
+ case $Xconnection in
DVI) ConnectedMonitor="tmds1,nocrt1,notv";;
VGA) ConnectedMonitor="crt1,notmds1,notv" ;;
TV) ConnectedMonitor="tv,nocrt1,notmds1"
- echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
- echo "Option \"TVFormat\" \"$XTVconnection\"" >> /tmp/options
- ;;
+ echo "Option \"TVStandard\" \"$XTVstandard\"" >>/tmp/options
+ echo "Option \"TVFormat\" \"$XTVconnection\"" >> /tmp/options
+ ;;
- esac
+ esac
- if [ x$XignoreEDID = x1 ]
+ if [ x$XignoreEDID = x1 ]
then
DS=" DisplaySize $XDisplaysize"
HS=" HorizSync $XHsync"
VR=" VertRefresh $XVrefresh"
- else
+ else
DS="# Display size edid used "
HS="#Hsync edid used "
VR="#Vertrefresh edid used "
fi
- echo "Option \"ForceMonitors\" \"$ConnectedMonitor\"" >> /tmp/options
+ echo "Option \"ForceMonitors\" \"$ConnectedMonitor\"" >> /tmp/options
- sed -e "s/^.*Modes.*$/\t $ML/" \
- -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
- -e "s/^.*DisplaySize.*$/ $DS/" \
- -e "s/^#.*HorizSync.*$/ $HS/g" \
- -e "s/^#.*VertRefresh.*$/ $VR/g" \
- -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.ati > $XORG_CONF
- ;;
+ sed -e "s/^.*Modes.*$/\t $ML/" \
+ -e "/INSERT MODELINE/r $TEMPLATES/xorg/modeline.$Xcatagory" \
+ -e "s/^.*DisplaySize.*$/ $DS/" \
+ -e "s/^#.*HorizSync.*$/ $HS/g" \
+ -e "s/^#.*VertRefresh.*$/ $VR/g" \
+ -e "/INSERT HERE/r /tmp/options" $TEMPLATES/xorg/xorg.conf.ati > $XORG_CONF
+ ;;
via|VIA|Via) echo "no via here"
;;
@@ -178,7 +178,7 @@ function setupX {
fi
;;
VMware )
- sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vmware > $XORG_CONF
+ sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vmware > $XORG_CONF
;;
VIA )
@@ -190,7 +190,7 @@ function setupX {
fi
;;
- Intel)
+ Intel)
sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.intel > $XORG_CONF
if [ ! x$TESTMODE = "xtest" ]
then
@@ -199,15 +199,16 @@ function setupX {
fi
;;
- vesa) sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vesa > $XORG_CONF
-
-
- *) #XCONF=`hwd -x |grep etc`
- XCONF=`hwd -x |grep etc|tr -d [:cntrl:]|cut -d\/ -f 2-`
-
-
- cat /$XCONF |grep -v Modes | sed -e '/Depth 16/a Modes "800x600"' -e 's/dev\/mouse/dev\/psaux/g'> $XORG_CONF
- ;;
+ vesa) sed -e "s/^.*Modes.*$/\t Modes \"${Xres}\"/" $TEMPLATES/xorg/xorg.conf.vesa > $XORG_CONF
+ ;;
+ *) #XCONF=`hwd -x |grep etc`
+ #XCONF=`hwd -x |grep etc|tr -d [:cntrl:]|cut -d\/ -f 2-`
+ XCONF=/root/xorg.conf.new
+ X -configure
+ echo $XORG_CONF
+ grep -v Modes $XCONF | sed -e '/Depth.*16/a Modes "800x600"' -e '/Depth.*24/a Modes "800x600"' -e 's/dev\/mouse/dev\/psaux/g'> $XORG_CONF
+ rm -f $XCONF
+ ;;
esac
fi
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index 21f196d..6403dbd 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=1.0
-pkgrel=12
+pkgrel=14
arch=('i686')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
diff --git a/abs/core-testing/LinHES-system/firstboot.sh b/abs/core-testing/LinHES-system/firstboot.sh
index 366874a..47aa0f9 100755
--- a/abs/core-testing/LinHES-system/firstboot.sh
+++ b/abs/core-testing/LinHES-system/firstboot.sh
@@ -3,7 +3,6 @@
ATTEMPT=0
function try_smolt {
((ATTEMPT=ATTEMPT+1))
- echo $ATTEMPT
status=$(echo "jump mythsmolt" | telnet localhost 6546 2>&1)
echo $status|grep -q refused
status=$?
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index 7d68dd4..2b60fba 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=5
+pkgrel=14
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core-testing/runit-scripts/runit.install b/abs/core-testing/runit-scripts/runit.install
index 4652368..4b97199 100755
--- a/abs/core-testing/runit-scripts/runit.install
+++ b/abs/core-testing/runit-scripts/runit.install
@@ -23,8 +23,7 @@ fi
post_install () {
mkdir /var/service
- ln -s /etc/sv/tty* /var/service
- servicelist="acpid cron frontend lircd ntpd alsa-utils avahi dbus portmap sshd"
+ servicelist="acpid cron frontend lircd ntpd alsa-utils avahi dbus portmap sshd syslog-ng tty2 tty3"
for i in $servicelist
do
ln -s /etc/sv/$i /var/service/$i
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/frontend/run b/abs/core-testing/runit-scripts/runitscripts/services/frontend/run
index 50e0e03..12a787d 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/frontend/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/frontend/run
@@ -1,6 +1,6 @@
#!/bin/sh
exec 2>&1
- grep -q nox /proc/cmdline
+ grep -qi nox /proc/cmdline
STATUS=$?
if [ $STATUS = 0 ]
then
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/lircd/finish b/abs/core-testing/runit-scripts/runitscripts/services/lircd/finish
index 3545b07..754bca1 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/lircd/finish
+++ b/abs/core-testing/runit-scripts/runitscripts/services/lircd/finish
@@ -1,12 +1,12 @@
#!/bin/bash
-killall -9 lircd
+killall -9 lircd 2>/dev/null
rm -f /var/run/lirc*.pid
+[ -e /etc/sv/lircd/.runtime ] || mkdir -p /etc/sv/lircd/.runtime
touch /etc/sv/lircd/.runtime/`date +%s`
numfiles=`/usr/bin/file_time_offset.py -s4 -d/etc/sv/lircd/.runtime `
if [ $numfiles -gt 3 ]
then
- rm -f /etc/sv/lircd/.runtime/*
- ls -la /etc/sv/lircd/.runtime/*
+ rm -f /etc/sv/lircd/.runtime/* 2>/dev/null
sv stop lircd
echo "lircd is not able to start, disabling it"
fi
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
index 57b1b48..0adfdc1 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/lircd/run
@@ -2,6 +2,7 @@
exec 2>&1
run_lircd2=false
. /etc/systemconfig
+[ -e /etc/sv/lircd/.runtime ] || mkdir -p /etc/sv/lircd/.runtime
function dvico_detect {
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/ntpd/run b/abs/core-testing/runit-scripts/runitscripts/services/ntpd/run
index 97302f1..65e551c 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/ntpd/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/ntpd/run
@@ -1,3 +1,3 @@
#!/bin/sh
-ntpdate pool.ntp.org
-exec ntpd -n -p /var/run/ntpd.pid
+/usr/bin/ntpdate pool.ntp.org
+exec /usr/bin/ntpd -n -p /var/run/ntpd.pid
diff --git a/abs/core-testing/runit/PKGBUILD b/abs/core-testing/runit/PKGBUILD
index 9890c74..c0863bb 100755
--- a/abs/core-testing/runit/PKGBUILD
+++ b/abs/core-testing/runit/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit
pkgver=1.8.0
-pkgrel=56
+pkgrel=57
pkgdesc="A replacement for sysvinit, and other init schemes, with service supervision"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core-testing/runit/runit.install b/abs/core-testing/runit/runit.install
index 4652368..977841b 100755
--- a/abs/core-testing/runit/runit.install
+++ b/abs/core-testing/runit/runit.install
@@ -22,14 +22,7 @@ fi
post_install () {
- mkdir /var/service
- ln -s /etc/sv/tty* /var/service
- servicelist="acpid cron frontend lircd ntpd alsa-utils avahi dbus portmap sshd"
- for i in $servicelist
- do
- ln -s /etc/sv/$i /var/service/$i
- done
-
+ mkdir /var/service
ln -s /sbin/halt.script /sbin/halt
ln -s /sbin/reboot.script /sbin/reboot
ln -s /sbin/poweroff.script /sbin/poweroff